[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ps - Illegal Instruction

On Sun, 19 Sep 2010 20:15:42 -0400, Jerry Stuckle wrote:


> I still have several problems, which may be related.  The easiest one to
> find is an "Illegal Instruction" when I run a simple ps command.  This
> occurs whether I run as a user or root.
> I've done a lot of looking, but don't seem to find anything similar.
> Does anyone have any ideas?

Have you try by performing a completely new install (by downloading a new 
iso image and verifying the checksum before installing)? 

Maybe something got messed-up and VM can be very "picky" when they find 
things they don't like. Also, debugging virtual machines is not an easy 
(neither pleasure) task :-)
> I'm still pretty much a noob on Linux, so please be gentle :)

Suggestions provided by other list users (like testing with another 
virtual machine) are also a very good idea.


- First, because is what many of us would have done in your same 
situation (it is very rare that running a simple "ps" command halts with 
"illegal instruction", that error message comes from the virtual machine, 
so VM is the first suspect here).

- Second, because Virtual PC is not a very good virtual machine (it lacks 
for many basic functions, technically speaking, there are better choices, 
such VirtualBox or Vmware Server).

A quick view of Wikipedia virtual machines comparison chart states so:


- Third, because by you'll get further (and better) support, at least 
from anyone here... being this a Debian user list, is not very probable 
that some of us were running a VM that cannot be installed in Debian by 
any means (well, maybe could be installed from Wine :-P).



Reply to: