[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

help needed in installing 3G+ usb modem

Hi to Everyone,

I have already tried a lot of things to get this to work on my laptop running Ubuntu 8.04. I also carried tests on my desktop on Debian Lenny, with no results in either system.

Some people got very similar models of 3G key to work on Ubuntu. They have recommended that I carry a few tests, but none gave satisfactory results, and they don't know what more to advise. I thought that, maybe someone here would have a better experience.

Whenever I plug that modem in a usb slot, it first acts as if it was a mass storage device. Nothing wrong with this, have I been told : the data space contains programs for MSWIN install. The device must therefore be switched so as to be reckognized as a modem, which may be done using various means. You need "usb-modeswitch" and "comgt" packages. None of them were on my system, nor were they available in the 'Hardy' repositories, so I went fetching them as .deb packages meant for a more recent distro. They seemed to have installed flawlessly. However, I can't get any result.

At first, I don't know how to launch usb_modeswitch. It may be that it is supposed to work automatically. In any case, my usbmodem does not switch from storage to modem. The man page is really poor, as it does not explain what you must exactly write in your statement :

   usb-modeswitch [-hvpVPmMrdHn] [-c filename]

with no mention of what target you must write after this.

sudo usb_modeswitch

Error : could not find file /etc/usb_modeswitch.conf

I wrote one with two lines from an example taken from another version of usb_modeswitch, which version I could not install (this is a tarball which compiles here with errors). Then

sudo usb_modeswitch -c /etc/usb_modeswitch.conf

   No default vendor/product ID given. Aborting

Nowhere was it written that you had to specify a default vendor/product. I tried a few things as vendor/product, including what you find in the usb_modeswitch-data files for your modem, that is 19d2:2000 then 0x19d2/0x2000 and various other names... to no avail.

I tried :

sudo comgt -d /dev/ttyUSB0

comgt 20:44:46 -> -- Error Report --
comgt 20:44:46 -> Error @6 line 1, Can't control /dev/ttyUSB0, please try again

I can try any time I want, same result. It more often happens that, instead of the above message, I only get : "Can' open /dev/ttyUSB0. I also get this if I test USB1, USB2...

I have also tried the 'vodaphone' package which failed too.

My USB modem is a ZTE (Huwei abcd).

lsusb says :

   Bus 007 Device 007: ID 19d2:2000

dmesg says :

   usb 7-2: new high speed USB device using ehci_hcd and address 7
   usb 7-2: configuration #1 chosen from 1 choice
   scsi12 : SCSI emulation for USB Mass Storage devices
   usb-storage: device found at 7
   usb-storage: waiting for device to settle before scanning

(but if I wait, nothing changes)

That usb modem DOES WORK under MSWIN (I tried it)

I have got another one, of the same vendor, but from another mobile provider. For this other one, I still don't have the SIM card, still I tried it to see what would happen ; I even tried it with the alien SIM card in it. It does not work either, even though both models are known to work under Linux, as reported by several people on various lists. This one gives very similar messages with dmesg, same reply with comgt -d /dev/ttyUSB0, and lsusb says : ID 12d1:1446 Huawei Technologies Co., Ltd.

Thanks in advance for your comments

Reply to: