[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lenny boot problem

On Wed, 20 Jan 2010, amka wrote:

Le mardi 19 janvier 2010 à 23:03 +0000, Christian Koerner a écrit :
On Tue, 19 Jan 2010, amka wrote:
Le mardi 19 janvier 2010 à 06:45 +0000, Christian Koerner a écrit :
On Mon, 18 Jan 2010, amka wrote:
Le dimanche 17 janvier 2010 à 00:11 +0000, Christian Koerner a écrit :
On Sun, 17 Jan 2010, amka wrote:
Le samedi 16 janvier 2010 à 21:37 +0000, Christian Koerner a écrit :
On Sat, 16 Jan 2010, amka wrote:
On boot :

ramdisk: couldn't find valid ram disk image starting at 0
list of all partitions:
...         # I don't remember the line, and the last one is :

Kernel Panic - not syncing: VFS: unable to mount root FS on unknown
block (8,33)

Looks like it can't find the initrd image.

How many HDDs have you in your system?
3 : sda, sdb (etch) and sdc (lenny)

Can you boot into Etch or does it fail too?
The boot of etch is OK (lilo).

What filesystem do you use for lenny?
ext3 :

1. it's visible on /etc/fstab , and
2. On etch, I mounted /dev/sdc1 (='/' lenny) on :
debian:~# stat -f /mnt/wd01/
 File: "/mnt/wd01/"
   ID: 0        Namelen: 255     Type: ext2/ext3
Block size: 4096          Fundamental block size: 4096
Blocks: Total: 35325708   Free: 34536368   Available: 32741908
Inodes: Total: 8978432    Free: 8879709


I tried, see below (lenny lilo.conf ; no results...)

Do you use lilo also for etch? If so, can you send your lilo.conf from the etch installation.

etch lilo.conf :




#       restricted


Looks fine.

In your lilo.conf I would remove any options with "*bmp* and the "install" option.
Yes, and result : the boot problem subsists.

Had you a chance to disconnect drive sda & sdb as I would keep it as simple as possible. Hence remove also any options with bmp and the install option in your lilo configuration.
I did, and the problem subsists too (1 drive only and no bmp or install options).

When you tested with the Lenny HDD, did you change your lilo.conf before? So all /dev/sdc devices pointed to /dev/sda?

How I did :
1. I started my computer with the first lenny CD ;
  graphical rescue mode.
2. I mount /dev/sda1 for '/'
3. I went to shell (, got the mount and df results), and
  I changed my lilo.conf :

lenny lilo.conf (only 1 disk) :




The result was the same when I started with "lenny_1D" : kernel panic.

The lilo.conf looks ok. Did you run the lilo command after you made the changes to the lilo.conf?
Yes, and I change 'label' each time to be sure.

Just to be sure. ;)

All entries pointing to /dev/sdc need to be changed to /dev/sda in the /etc/fstab too.
I tried it (through CD recue mode), but 'kernel panic'.

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda1       /               ext3    errors=remount-ro 0       1
/dev/sda2       none            swap    sw              0       0
/dev/hdb        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdc        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

Is /etc/fstab so important if booting with CD rescue mode ?

Not for the rescue mode, just when you changed the lilo.conf to /dev/sda. However it panics  before...

The computer asks me which drive to mount as '/', and I have only the
choice between sda1 and sda2 (swap).

But when I enter in the shell, df prints /dev/sdc1 for '/'. (?)

To be sure can you provide the output of:
ls -la /boot/vmlinuz-2.6.26-2-amd64
-rw-r--r-- 1 root root 1755696 Nov  5 05:32 /boot/vmlinuz-2.6.26-2-amd64

ls -la /boot/initrd.img-2.6.26-2-amd64
-rw-r--r-- 1 root root 6670848 Jan  6
19:20 /boot/initrd.img-2.6.26-2-amd64

And a strange thing :
- The rescue mode invited me to mount /dev/sda1 on '/' , normal, but...
- df prints /dev/sdc1/ (and not sda1) as '/'  ??
- Changing /etc/fstab or SATA connectors on my drive didn't change anything.

Can you please send the output of mount and df when you use one disk only.

Here you have them :


Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sdc1            141302832   3157216 130967776   3% /
tmpfs                141302832   3157216 130967776   3% /lib/init/rw
udev                    514680       660    514020   1% /dev
tmpfs                   514680       660    514020   1% /dev/shm
devpts                  514680       660    514020   1% /dev/pts


dev/sdc1   on /             type ext3  (rw,errors=remount-ro)
tmpfs      on /lib/init/rw  type tmpfs (rw,nosuid,mode=0755)
proc       on /proc         type proc  (rw,noexec,nosuid,nodev)
sysfs      on /sys          type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev       on /dev          type tmpfs (rw,mode=0755)
tmpfs      on /dev/shm      type tmpfs (rw,nosuid,nodev)
devpts     on /dev/pts     type devpts (rw,noexec,nosuid,gid=5,mode=620)

Don't see any unusual there, apart from the point that you mount /dev/sda1 as "/" and it is not listed.
Can you please send also the output of: fdisk -l

Disk /dev/sda: 150.0 GB, 150039945216 bytes
255 heads, 63 sectors/track, 18241 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x7fec6c1c

  Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       17872   143556808+  83  Linux
/dev/sda2           17873       18241     2963992+  82  Linux swap /

And : ls -l /dev/sd*
brw-rw-rw- 1 root root 8, 0 Jan 20 22:22 /dev/sda
brw-rw-rw- 1 root root 8, 1 Jan 20 22:22 /dev/sda1
brw-rw-rw- 1 root root 8, 2 Jan 20 22:22 /dev/sda2

But df prints sdc1 (CD resue mode).

An other thing :
I am using an 'old' mainboard and the disk is new (WD1500HLFS).
I allready had problems when I trid to use a too big HDD (1TB) ; it was
not recognised and Tyan informed me that I have to upgrade my BIOS.

I doubt this can have 'kernel panic' result.

Not sure, it could be that the disk geometry is not detected properly and so it fails.
IMO all your configs are ok.

Alternativ is to give grub a go but you said you had problems with grub as well.

On what HDD/partiton did you install lilo?
On sdc. I tried sda, but the problem subsist.

Do you boot directly into Lilo or do you use another bootloader that starts Lilo?

Lilo starts first.

Another thing I saw :
On boot, an error/warning occurs :
[  [0.260762  PCI ]  cannot alocate ressource region 0 for device

I am not sure for the quite text (it goes fast, but :
- The first number is correct,
- 'region' is '0' and
- 'device' is "a lot of" 0.

debian:/home/amel# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-8151 System
       Controller (rev 13)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8151 AGP Bridge
       (rev 13)

My TYAN Tiger K8W (S2875) mainboard seems to be supported.

Kind regards

Sorry amka, but if you find a solution please let me know.



Reply to: