[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.30 (Squeeze): no hda1 no sda1

Paul Gallaway wrote:

>> I need just a bit of reassurance because I really don't want to paint
>> myself into a corner. If I start playing around with fstab won't that
>> jeopardise my ability to boot into the 2.6.26 kernel? If it doesn't
>> effect 2.6.26 then I don't understand how editing fstab would make a
>> difference to being able to boot in 2.6.30.
>> Thanks again
>> jonathan
> First of all, back up your fstab /before/ you start messing with it.
>>From busybox you can always manually mount the drive and revert to the
> present semi-working version.
>>From what you've described to the list, your root drive is detected
> under 2.6.26 and 2.6.30 as different devices - and under 2.6.30 it may
> not be detected at all. What you're doing by changing to the UUID or
> label is instead of pointing to a /dev location (which as you're
> experiencing can change between kernels and for other reasons) you're
> pointing to the drive label or UUID. Neither will change without some
> sort of user intervention. The Label can't be added/changed without
> formatting (something that might wipe your disk) and UUID will be the
> same no matter what kernel you're using so if you do it correctly then
> 2.6.26 will continue to work as it does now even if 2.6.30 still fails
> to boot (see below). E.g. if you give the UUID for your /var partition
> as the root partition then you're still going to have problems due to
> user error. Just comment out your current line for /dev/hda and make a
> copy of that line replacing /dev/hda with UUID=.... or LABEL=... and
> you should be on your way. There's lot's of examples if you google
> UUID+fstab+debian for the tools you need to figure out the UUID for
> your drives.
> If you do mess it up you can always mount the /dev/hda location
> manually from busy box, revert your fstab from the mounted location
> and then boot normally and try to assign the correct UUID again.
> What if it still doesn't work?: If you change to UUID mount points and
> 2.6.26 will still boot and 2.6.30 still won't boot then you're
> probably missing a driver in the 2.6.30 kernel for some of your
> hardware that you need for your system to boot properly.
Thanks Paul. I think I tried to edit /etc/fstab using vi from busybox but 
when I invoked it the file came up empty and there was a read-only 
indication somewhere.
I understand what you're saying but up to now, using the root=UUID=xxxxxx 
does not work but I have not done that when I have ALSO changed the fstab 
designation to the UUID. I can try that but I'll have to check on the syntax 
for specifying UUID in the fstab file.

What's funny is that Sidux, using 2.6.30 finds the hard drive with no 
problem at /dev/sda1 and yet Squeeze with 2.6.30 can't find it there. The 
only kernel-specific driver I'm using now is for my ancient webcam, gspca, 
which is certainly not critical for the kernel to function normally. It 
remains a mystery.
Registerd Linux user #445917 at http://counter.li.org/

Reply to: