[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: how to solve the problem "Could not bind sock on port 21: Address already in use"?

On Thu, Mar 5, 2009 at 10:48 PM, Robert Brockway
<robert@timetraveller.org> wrote:
> On Thu, 5 Mar 2009, Star Liu wrote:
>> i changed the port my ftp server use, then it starts. it's good, i'm
>> not so stupid.
> Hi Star.  I'd recommend against solving the problem that way.  Ports are
> standardised so they may be found easily by those who needs them.
> As others have noted Inetd is the Internet superserver.  If you look in
> /etc/inetd.conf (or /etc/xinetd.* if using xinetd) then you should see an
> entry where it is starting an ftp server on tcp/21.  It shouldn't be
> starting anything else there unless you have a honeypot set up.
> So I'd recommend finding out what Inetd is starting, disable it and start
> your ftp server on the correct port.
> Having said that I wouldn't recommend ftp for anything except anonymous
> access.  sftp is now widely supported in file transfer clients even on
> MS-Windows.  sftp is a lot more secure and doesn't have any problems with
> firewalls like ftp does.
thank you, I have stopped inetd using 21 port by commenting out that
line about ftp, but unfortunitely, I have not setup my ftp server, it
seems the best ftp server is proftpd, but sid doesn't support
it(why?), then how could i setup a ftp server on sid? I have tried
more then 5 ftpd servers, like wzdftpd, pureftpd,...., but none is
successful, any suggestion? thanks
> Cheers,
> Rob
> --
> I tried to change the world but they had a no-return policy
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org with a subject
> of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: