[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: my new Inspiron - WAS: OT: laptop recomendations

Stackpole, Chris wrote:

From: Bernard [mailto:bdebreil@teaser.fr]
Sent: Monday, January 05, 2009 3:30 PM
Subject: my new Inspiron - WAS: OT: laptop recomendations

For I have not been able to get WiFi working so far !

The UBUNTU v8.04 Gnome Desktop proposes a few things to get wifi
working, but it does not work here. On my Desktop computer (running on
Debian Sarge half upgraded to Etch), WiFi works on my DSL box/router,
whether with WEP or WPA encryption. My old Thinkpad 600 worked WiFi
on WEP encryption. This one does not work at all so far ; no doubt
it is my mistake, but I'd like to kwow which one is mine. The
process "network tools" has not given any success. I have tried to
insert my WPA encryption key in /etc/network/interfaces as I have done
on my Desktop, but I had no success. A ping on gives no
result either. I have not forgotten to switch the side button that is
supposed to switch the network ON/OFF.

If you have not used Ubuntu recently,

This is my first encounter with Ubuntu... and it is rather hard, ever since I also have to cope with Gnome which is also not familiar to me (used to fvwm). One of the first things that I learnt about Ubunto, is that, by default, the user cannot become superuser (su) using the root pasword ; also, when you open your new machine with Ubuntu installed, it is not being proposed that you register a user "root". Instead, you are supposed, for any action that requires permission, to type :

sudo /etc/init.d/networking restart (for instance), and the system then requires you to provide your own user pasword.

Problem is that it no longer works here, and I don't know how to recover from this. I don't know why it no longer works, I gwess I must have changed something in my config, local parameters or else. It says :

sudo : unable to resolve host dell-desktop

The shell that appears on my Xterm is :


I can't remember what that shell was yesterday, maybe it has changed... it was 3 in the morning. In any case I hope I can get this fixed.

the wireless configurations are
/much/ different then they were in Debian Etch. Try using "network
manager"; I bet the icon is in the top right of your screen by the clock
(looks like 2 computers). Left click to see the wireless networks it has
found, right click to see the properties information.
I have just tried this. A left click on the icon just proposes a "manual config" (it also shows a grayed line "Cabled network". After awhile, a box appears though, but the box is blank. At this stage, the system has been up for at least 30 minutes. So, I clicked to "manual config". Once there and after authentification with my pasword (it still works there), I clicked on "wireless connexion" and "properties". Once there, I deactivated the "roaming mode" (I hope there is no confusion in the translation, since most everything is in French on that laptop). Once that mode deactivated, the blue network light came on in the front left of the machine ; it was out before... Ah YES, I just carried another trial... true enough, the blue light did come in only after I deactivated roaming, but, this time, when I tried to reactivate it, the light did not came out and I got two networks available, one is my neigbour's, the other one is mine. I gave the pasword as required, and it seems to reach a connexion... the former icon is being replaced by four bars... If I get the pointer on it, it says : "connection to wireless network Livebox-46db (0%). Now, if I ping my livebox, it says "Network is unreachable" and, if I launch Firefox, http addresses are not found. While testing on my desktop on Debian Sarge, that is, about three months ago, using ifup and ifdown and /etc/network/interfaces, I think that I found that what made the difference was the mode (Managed or else), but on that laptop with Ubuntu, I don't know how to change this ; it may also be another reason why it does not work.

I will reply your other questions later on, since I am trying to get rid of my wifi problem first, also to that of my sudo pasword reckognition.

Also, right after
a fresh boot up, it will take a few minutes for it to scan/find wireless
networks (I kid you not, it takes a full 2 minutes to find my wireless
network on my Ubuntu 8.10 laptop). So give it time. Once it scans the
area, it should present a drop down menu of all the wireless networks
found (left click). If you have your SSID set to "hidden" you will have
to select the "connect to Hidden Network" option. Both options bring you
to the same menu where you can define your network, your encryption, and
your password/phrase. That should be it to get you connected.

If you try to do networking/wireless "the Debian way" in Ubuntu, you
have to disable/remove network manager first. You will have issues if
you don't. You will probably find that people tend to either love or
loath "network manager".

Do you recommend to give it a quick extra trial before installing
Lenny, or have I better switch right away ?

I would give it a trial. Also, please do yourself and anyone helping you
a favor and look at the hardware before hand. I have heard several
stories of these laptops being shipped with binary blobs for drivers.
Also, a friend got one of the first Ubuntu-preinstalled Dell laptops. We
were unable to get Etch to install and we were unable to get Lenny
working right. The latest Sid and Ubuntu worked though (This was almost
a year ago so I hope things have changed for the better). If I were you
I would look through all the hardware and do a few Google searches to
make sure that the Debian version you are going to install will work (or
at least find out how much work it will take to get the drivers to

I hope this helps. May the drivers be included on install and your
configuration smooth!

Have fun!

Reply to: