[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Exim4 Incompatable Command Line Arguments

On Thursday 24 April 2008 08:41:24 debian-user-digest-request@lists.debian.org 
> On Wed, Apr 23, 2008 at 10:35:59AM +0300, David Baron wrote:
> > After yesterday's upgrades (NOT including exim4 packages), I get a
> > failure to start exim4 running the /etc/init.d/exim4 script.
> >
> > If I manually run with presumably the same arguments, i.e. exim4 -bd
> > -q30m, all is well.
> >
> > Anyone had this problem, fixed it?
> See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=477194
> and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=406059
> The problem actually appears to be caused by lsb-base. One respondent to
> the bug report stated that downgrading lsb-base to 3.2-8 fixed it for
> him. I didn't have 3.2-8 in my archive and was too lazy to track it down
> so I downgraded to 3.2-7 and was then able to start Exim normally.

OK. But since I can start it from the command line with the normal arguments, 
maybe the problem is with the daemon tools packages that are used by the 
init.d startup scripts. Then again, most every  other daemon is going through 
this (including lsb-base?) without a hitch.

Anyway, lsb-base 3.2-8 or -7 from testing?

Reply to: