[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /usr/lib/cups/filter/foomatic-rip failed

On Wed, Mar 12, 2008 at 09:31:23AM +0100, Gerard Robin wrote:
> On Tue, Mar 11, 2008 at 01:05:35AM +0100, s. keeling wrote:
>> From: "s. keeling" <keeling@nucleus.com>
>> To: debian-user@lists.debian.org
>> Subject: Re: /usr/lib/cups/filter/foomatic-rip failed
>> Gerard Robin <g.robin3@free.fr>:
>>>   My printer HP Photosmart C7280 printed fine until I upgraded my sid 
>>> box
>>>  and now cups gives:
>>>  /usr/lib/cups/filter/foomatic-rip failed
>>>  (the script perl /usr/lib/filter/foomatic-rip exits on my system)
>>>  hp-setup (as root) gives:
>>>  Session management error:  Authentication Rejected, reason : None of 
>>> the authentication protocols  specified are supported and host-based 
>>> authentication failed
>>>  I can't print anything now, SOS ...
>> I'd worry about that Authentication Rejected bit first.  Then try
>> falling back to another model name of the same type printer, an
>> earlier version.  I used an Epson that way recently.
> --------------------------8<--------------------------------
>> I thank the DDs for their efforts in making this possible.  I had a
>> devil of a time trying to do this in Sarge, but Etch appears far more
>> amenable to nutbars like us non-CUPS users.  Great job!
> My problem is partialy solved:
> I have downloaded the ppd driver for my HP Photosmart C7280 at:
> http://www.openprinting.org/show_printer.cgi?recnum=HP-PhotoSmart_C7200
> and I replaced the driver supplied by the debian package by this one and
> now hp-setup and hp-toolbox work fine but:
> I can scan a document.
> I can make a copie of a document (from the computer)
> I can't print a file, always I get: /usr/lib/cups/filter/foomatic-rip 
> failed 

I've had a number of occaisions where cups has just failed for me like
that with a "...foomatic-rip failed" message. On different occaisions
I've had different solutions work: 

     purge cups* and foomatic* and
     anything else printing related I can find and start over 

     remove ~/.gnome (not sure why this worked, but it did once).

     remove the existing printer, shutdown cups completely, restart it
     and re-add the printer

     other mysterious mumbo-jumbo that magically fixes printing... :(

It's a big complicated system and seems overly prone to breakage IMO.


Attachment: signature.asc
Description: Digital signature

Reply to: