[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: using a remote IMAP server and smarthost

On Sun, August 26, 2007 22:53, Florian Kulzer wrote:
> Maybe the smarthost does not use TLS (an encryption wrapper) because it
> is only dealing with internal connections from trusted VMs. I would
> start simple on the VM, with this ~/.msmtprc:
> #-------------------------
> tls off
> auth plain
> password YOUR_PASSWORD
> #-------------------------

Done that.  Sending from the VM, now I get

msmtp: the server does not support DSN
msmtp: could not send mail (account default from /home/richard/.msmtprc)

I tried with no auth and with auth off and get the identical result,

Reading the manual again, I see that DSN is Delivery Status
Notification.  Although it is the default, I have tried specifying
dsn_notify off, but still get the same error.

Info on the ISP's smarthost from their site:

and we will relay messages that fulfill the following criteria:

    * The envelope MAIL FROM: address must be routable (i.e. exist and
have a valid MX record)
    * The envelope RCPT TO: address must also be routable.
    * To connect to the relay your host IP address must be in the Bytemark
IP range.
    * The message must be 20MB or smaller.
    * Your machine is not sending more than 240 messages every 6 hours.

Only the first two could be a problem AFAICS.   How do I get to see the
envelope msmtp is trying to send?

I also ran msmtp -S which gives:

SMTP server at smtp.bytemark.co.uk (tallyho.bytemark.co.uk
[]), port 25:
    tallyho.bytemark.co.uk ESMTP Exim 4.50 Mon, 27 Aug 2007 08:29:32 +0100
    SIZE 20971520:
        Maximum message size is 20971520 bytes = 20.00 MB
        Support for command grouping for faster transmission

Where now?



Reply to: