[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Java has stopped working (Partially SOLVED)

Alex Samad wrote:
On Sat, Aug 11, 2007 at 01:46:46PM -0700, Marc Shapiro wrote:
John W. Foster wrote:
On Saturday 11 August 2007 00:09, Marc Shapiro wrote:
I just realized that java is no longer functioning on my up-to-date Etch
system.  I had installed Sun Java using java-package and it had been
working at the time.  I don't run java all that much, so I don't know
just when it stopped working, but it is not working now.  I have used
the test on Sun's site and it does not find my installation.  JAVA_HOME
had been set to /usr/lib/j2sdk1.5-sun.  When Sun's own site could not
find my installation I decided that it was time to uninstall and
reinstall fresh.  I ran:

    aptitude remove sun_j2sdk1.5

aptitude suggested installing what appears to be Debian java packages to
replace the Sun package.  I agreed and the installation seemed to go
smoothly, but I am still unable to run java packages, from Sun's site,
or others.  Do I need a plugin of some sort?  When I tried to install
sun-java5-plugin aptitude wanted to install Iceweasle.  Since I am
happily running Firefox 2.0 I do not want to install Iceweasle.  How do
I get around this?

Can someone tell me what I might be missing, or point me in the right

Marc Shapiro
try removing any debian packages with 'gcj' as part of the name for examplegcj; or any app named something-gcj. I ahve run into some conflicts with that recently. If that fixes the problem then there is most likely a bug in gcj, which I have not reported, since I was not certain it existed.
I don't have any 'gcj' packages installed.

I don't want to install Iceweasle.  I am happy with my upstream Firefox.

I Think that I have a partial answer to the problem, but I don't seem to be able to implement it -- There was no java plugin in my .mozilla/plugins directory. I made a link to the plugin in /usr/lib/jvm/java-1.5.0-sun- but that made no difference. I then tried linking to the plugin in /usr/lib/firefox. This time, the check for java on Sun's site found my installation, but said that I don't have the correct version of java installed, so I downloaded the new .bin file and tried to use make-jpkg on it, but I got the following message:

mns@xander:~$ make-jpkg jre-6u2-linux-i586.bin

you should not need to do this all the packages need are in the main debian repos.

another tool to use to check when there are problems with java (because of the different versions installed) update-alternatives, check ls -l /etc/alternatives | egrep java\|jvm\|sun
I shouldn't need to, but if you check what I said previously (2nd paragraph of original post), I installed the Debian packages but that did not help, even after I added the link to the plugin.

What I ended up doing was to simply install Sun's java package without creating a Debian package and then updated my JAVA_HOME environment variable and the link to the plugin. This now has java working, but I also need to have the Debian packages installed to satisfy the dependancies of Debian's OOo packages.

Is it possible to uninstall the Debian java packages (i.e. sun-java5-jre and its dependancies) without messing up my OOo installation?

Marc Shapiro

Reply to: