[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Java has stopped working

I just realized that java is no longer functioning on my up-to-date Etch system. I had installed Sun Java using java-package and it had been working at the time. I don't run java all that much, so I don't know just when it stopped working, but it is not working now. I have used the test on Sun's site and it does not find my installation. JAVA_HOME had been set to /usr/lib/j2sdk1.5-sun. When Sun's own site could not find my installation I decided that it was time to uninstall and reinstall fresh. I ran:

   aptitude remove sun_j2sdk1.5

aptitude suggested installing what appears to be Debian java packages to replace the Sun package. I agreed and the installation seemed to go smoothly, but I am still unable to run java packages, from Sun's site, or others. Do I need a plugin of some sort? When I tried to install sun-java5-plugin aptitude wanted to install Iceweasle. Since I am happily running Firefox 2.0 I do not want to install Iceweasle. How do I get around this?

Can someone tell me what I might be missing, or point me in the right direction?
Marc Shapiro

Reply to: