[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Enabling SFTP under Debian 4.0r0

On Jul 6, 2007, at 11:54 PM, Kent West wrote:

ArcticFox wrote:

On Jul 6, 2007, at 10:04 PM, Kent West wrote:
Again, what happens when you attempt to connect from/to the same Linux box?

If that works, try from the Mac Terminal instead of Fugu and let us know the results.
Both the remote terminal and local terminal give the same error. (Request for subsystem... blah blah blah)

I think at this point I'd try "aptitude purge ssh && aptitude install ssh", from the command line. (It's irrational, I know, but I just don't trust Synaptic as much as I do aptitude.)

I'll try that.... Seems ssh wasn't installed beforehand (aptitude purge ssh had no effect) though it still dosen't work after installing ssh. I suppose I need to restart now though right?

Does the error occur after entering your password, or before you even get a password prompt?

After entering the password. Tried it three times then get the error message

But you can ssh fine? What about scp?

Yup, I didn't know about scp before >_> That solves half my problem though, I still need sftp to work...

You might "tail /var/log/auth.log" for clues.

All that tells me is there was a ssh session opened for root then closed a second later. No error messages or anything useful.

Can you verify that /usr/bin/sshd is running (as opposed to some other sshd)? As in:
westk[@westk03]:/home/westk> ps ax | grep ss[h]
17652 ?        Ss     0:00 /usr/sbin/sshd

I get no output for ss[h], but for ssh I get:
fox@foxpaws:~$ ps ax | grep ssh
11703 pts/0    S+     0:00 grep ssh
Not sure if that's meaningful or even what you were looking for. I didn't run it as root though, so that might have something to do with it.

Running as root I see:
11746 ? Ss 0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session x-session-manager

Also, I don't know if this is related, but attempting to connect through ssh as root gets a "Bad Password" message, yet the password is accepted when used locally.
IIRC, it used to be that sshd_config had "PermitRootLogin=no", but I think in more recent times it's set to yes (which seems unwise to me).

Reply to: