[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Automounting USB drive on GNOME stopped working...

Hash: SHA1

Ron Johnson escreveu:
> On 07/02/07 09:35, Cassiano Bertol Leal wrote:
>> Hash: SHA1
>> Hi
>> I have been having problems with automounting USB drives in GNOME. It
>> used to work flawlessly, but suddenly stopped (I know that 'suddenly
>> stopped' is a bit too vague, but that's what I've got...).
>> I am not in front of my home computer right now, so I will give details
>> as they come to memory, sorry about that.
>> CDs get automounted perfectly. USB drives used to work as well. The two
>> drives that I have tested were a Kingston 1GB pendrive and an HDD MP3
>> player from Cowon, which acts as an external HDD when plugged in the USB
>> port. They are both behaving the same way: when I plug the device in the
>> USB, it will load the drivers and assign a /dev/sd* node. They both work
>> ok if I manually mount them.
>> I have checked if gnome-volume-manager is running, and it is. I have
>> killed it and re-run it with -no-daemon and watched the output.
>> It will detect the drive, but then it says something like 'not a
>> mountable volume' and remove it from automounting... I am running a mix
>> system of lenny and sid, and have tried packages from both, notably
>> udev, hal and gnome-volume-manager and no success..
>> Any ideas?
> Have you updated any packages lately?
> Have you run "tail -n40 -f /var/log/syslog" while plugging in the pen
> drives?  Or is that what you mean by "it will load the drivers and
> assign a /dev/sd* node"?

I will have a look at syslog when I get back home. I have monitored
/var/log/messages and that's where I watched the pendrive and the MP3
being recognized and and the /dev/sd* being assigned to them.

Also, there's the fact that a simple 'pmount /dev/sda1' (for example) or
a 'mount -t vfat /dev/sda1 /media/whatever' will mount the drives with
no problems whatsoever.

I have definitely updated packages, and even fiddled around with
downgrading some from sid to lenny to try and make it work as before, to
 no avail. I also use a compiled 2.6.21 kernel, but I have tried the
latest stock one (2.6.18, IIRC) and had the same results.

Cassiano Leal
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: