[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xen-tools freezes (debootstrap)

On Tue May 22, 2007 at 23:01:08 +0200, Lars wrote:

> I'm running a Debian Etch xen-server and I'm having problem with the
> xen-tools are freezing up when i create DomU's and i have to reboot.

  That's not good.

> But it happens randomly, sometimes I can create DomU in the first
> attempt, some times it takes 3-5 attempts. I've tried creating DomU
> manually with debootstrap, but with same result.
> http://www.option-c.com/xwiki/Create_a_Debian_VM_with_debootstrap

  So you're saying that using debootstrap manually, without xen-tools
 causes a freeze?
  That suggests to me that the xen-tools are not at fault, since they
 also eventually delegate most of the work to debootstrap.

> I've disabled /lib/tls and tried booting with "noapic nolapic
> acpi=off", but no luck.

  I'd suggest it might be network/disc related.  Since the kernel
 is old in real terms there are sometimes issues.  Until I upgraded
 my Sid system to the 2.6.20x kernel I found Xen would randomly
 crash on heavy I/O, or network traffic.

> I haven't reported it as a bug yet. Most of all because of it
> happens so random and cause I'm not sure of if the problem lies with
> xen-tools, debootstrap or a third option.

  I think a xen-specific issue, since it is hard to see how debootstrap
 could crash your system.

> Another thing, xen-tools ignores when I define a role,
> "--role=basic". I also tried the ones that comes with the xen-tool,
> such as "gdm". I also tried to define --roledir and the absolute
> path to the role, but no luck. The skeleton directory works fine
> though...

  That sounds like a bug.  Report it to the BTS or I'll probably
 forget to take a look properly.  Still if you're running Etch you'll
 not see the fix unless you use the etch backported package available
 from my site / the homepage.

  (Hmmm I've not uploaded the current release just yet.  Will do that
# Commercial Debian GNU/Linux Support

Reply to: