[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sound problems... had OSS working... now neither ALSA or OSS works (complicated)

I tried switching to ALSA earlier today... seeing how it is the newer
thing.  Also, I'd hoped of getting sound working in IceWeasel --specifically
in Flash animations.

I know the Flash animation problem can be solved with 'Full duplex' i.e.

Full duplex (off) is supposed to fix this problem:
K Menu --> Control Center --> Sound System --> Hardware --> Full duplex (no check mark)

Described here:,+no+sound,+debian&hl=en&ct=clnk&cd=1&gl=us

However, it didn't do anything for me.  So, I decided to embark on installing ALSA... figuring it might be the bug fix.

ALSA seemed to install alright... but sound never worked.
At first it seemed to be a permissions issue... but I think that is now sorted.

To test this definitively I did the following:
$ XAUTHORITY=$HOME/.Xauthority
$ su root
# xmms
XMMS didn't produce any sound... or any errors.

As far as I can tell ALSA is installed:
# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.8 (Thu Jan 13 09:39:32 2005 UTC).

I hardware is there:
# cat /proc/asound/cards
0 [A5451          ]: ALI5451 - ALI 5451
                     ALI 5451 at 0x1000, irq 11

# lspci -v
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
        Subsystem: Toshiba America Info Systems Unknown device 0221
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at 1000 [size=256]
        Memory at 20000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2

aplay seems to detect the hardware...

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: A5451 [ALI 5451], device 0: ALI 5451 [ALI 5451]

If I give it a file--it seems to play it... though in mono and I don't hear anything.
# aplay "Bach - Conzona in D minor - BWV 588.mp3"
Playing raw data 'Bach - Conzona in D minor - BWV 588.mp3' : Unsigned 8 bit, Rate 8000 Hz, Mono

I think the right kernel modules are loaded:

# lsmod |grep snd
snd_pcm_oss            53344  0
snd_mixer_oss          19872  1 snd_pcm_oss
snd_ali5451            23556  0
snd_ac97_codec         78360  1 snd_ali5451
snd_pcm                92712  3 snd_pcm_oss,snd_ali5451,snd_ac97_codec
snd_timer              24644  1 snd_pcm
snd                    55300  6 snd_pcm_oss,snd_mixer_oss,snd_ali5451,snd_ac97_codec,snd_pcm,snd_timer
soundcore               9664  1 snd
snd_page_alloc         10020  1 snd_pcm

I'm NOT reassured by the numbering above.  I wonder about the '0' behind 'snd_ali5451'.

The trident driver (OSS) is not load (as shown above)-- I tried different variations with and without the driver. 'alsact' (alsactl = advanced controls for ALSA soundcard driver) seems to want the OSS driver around... though I haven't found a reason why it shouldn't work without it.  

Adding the trident driver seems like a complication at this point.  So, I decided not to load it.

In any case, I wondered whether the trident driver blocks the sound-- by loading first.  To test this I specified the 'snd_ali5451' ahead of 'trident' in my '/etc/modules' files.  This didn't do anything for me.

I used ALSA config tool to set-up ALSA, i.e.: 

# alsaconf
Unloading ALSA sound driver modules: snd-ali5451 snd-ac97-codec snd-pcm snd-timer snd-page-alloc.
Building card database...

Running update-modules...
Loading driver...
Setting default volumes...
Saving the mixer setup used for this in /var/lib/alsa/asound.state.


 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!

The above modifies '/etc/modprobe.conf'

The following was my modprobe.conf file:
# more /etc/modprobe.conf
install trident /sbin/modprobe --ignore-install trident && /usr/sbin/alsactl res
tore >/dev/null 2>&1 || :
remove trident { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprob
e -r --ignore-remove trident
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias scsi_hostadapter alim15x3

trident is the OSS driver.  I wondered whether this is creating a conflicit.
I removed the top two lines and removed the trident module.  It didn't help me 
get sound.

The one thing it did do is -- give me noise on the speakers when I did the following
test (as suggested here -- http://xtronics.com/reference/Debian-sound.html ):

# alsactl store
# speaker-test

speaker-test 1.0.13

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 32 to 32768
Period size range from 32 to 32768
Using max buffer size 32768
Periods = 4
was set period_size = 8192
was set buffer_size = 32768
 0 - Front Left
Time per period = 2.221005
 0 - Front Left
Time per period = 2.901268
 0 - Front Left
Time per period = 2.901266
 0 - Front Left


I have wondered about the trident driver-- and I currently have another issue (described
here: http://www.debianhelp.org/node/4696 -- unanswered... previously posted to the list)
which I suspect may be related to it, which is stopped me from upgrading my kernel.

I have the addition trident package installed i.e.:
# apt-get install xserver-xorg-video-trident
xserver-xorg-video-trident is already the newest version.

(not sure if this has anything to do with it)

Above said, I can't figure-out how to go back to OSS.  I'd be happy to abandon the
idea of ALSA... but I'm stuck 'cause I can't get it to work and I can't go back.

I tried UNDO-ing --going back to OSS by:
# apt-get remove alsa alsa-utils
# vi /etc/modprobe.conf
	remove first two lines

cobalamin:/etc/init.d# mv alsa DELETE__alsa
cobalamin:/etc/init.d# mv alsa-utils DELETE__alsa-utils

 rmmod snd_ali5451
 rmmod snd_ac97_codec
 rmmod snd_pcm
 rmmod snd_timer
 rmmod snd_page_alloc
 rmmod snd

 modprobe trident


Trying to fix this... or go back...

I've rebooted half a dozen times... wondering whether there are modules I'm missing.
I've tried to reconfigure packages.
I removed and re-installed 'linux-sound-base'
I tried to reconfigure 'linux-sound-base' ... in the hope of finding a place to say
I want to go back to OSS.

I can run 'alsamixer'.
Interesting about that is-- the volume is zero for everything.  I played with the volumes... no effect.

KDE tells me "Mixer cannot be found" and gives me the loud speaker with the "X" on it.

In KDE -- if I specify ALSA it gives me the following message (after attempting to re-start the sound system):
Informational - artsmessage
Sound server informational message:
Error while initializing the sound driver:

device: default can't be open for playback (No such device)

The sound server will continue, using the null output device

Interesting about the above is that... if I do "Autodetect" or "Open Sound System" in KDE (K Menu --> Control Center --> Sound & Multimedia --> Sound System --> Hardware) --- I do NOT get the above error message.

Also, interesting is that there's a 'snd_trident' (ALSA driver)... but 'alsaconf' doesn't seem to consider this.  

I have the impression the problem lies with the driver (snd_ali5451) -- but don't know where to go from here.  

I'd like to get ALSA working... but I'd also be happy if I could get back to OSS (which worked quite well-- with the exception of Flash in IceWeasel).
The nowhere land without sounds is really annoying...

Any help would be much appreciated!


Toshiba Satellite A20 -- A20-31Q: 2.53GHz (PSA20C-0231Q)

Processor: Intel Pentium IV, 2.53GHz

Memory: 512 MB

Install log: http://individual.utoronto.ca/bonert/debian_install.html

Debian GNU/Linux release: testing

Kernel: Linux version 2.6.11-1-686 (dannf@firetheft) (gcc version 3.3.6
(Debian 1:3.3.6-6)) #1 Mon Jun 20 22:00:38 MDT 2005

KDE: 3.5.5

Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen! 
Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer

Reply to: