[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [etch] apt_preferences issues

On Wed, May 16, 2007 at 18:46:48 +0200, Jakub Narojczyk wrote:
> Florian Kulzer napisał(a):
>> You are missing the blank lines to separate the records:
>> $ man apt_preferences | awk '/Effect/,/^$/'
>>    The Effect of APT Preferences
>>        The APT preferences file allows the system administrator to control 
>> the
>>        assignment of priorities. The file consists of one or more 
>> multi-line
>>        records separated by blank lines. Records can have one of two 
>> forms, a
>>        specific form and a general form.
>> If it still does not work with separated records then you should post
>> the output of e.g.
>> apt-cache policy gimp
> records are separated by blank lines. I just didn't know that those blanks 
> were essential and compressed the listing in the e-mail. sorry about the 
> confusion. and it still doesn't work.
> $ apt-cache policy gimp
> gimp:
>   Installed: 2.2.13-1
>   Candidate: 2.2.13-1
>   Package pin: 2.2.13-1
>   Version table:
>      2.2.13-1 1001
>         500 ftp://ftp.task.gda.pl etch/main Packages
>  *** 2.2.13-1 1001
>         100 /var/lib/dpkg/status

To me that looks like the pinning worked and I do not understand how apt
can think of "upgrading" to the same version. Is your currently
installed gimp a version from another repository?

What happens if you ask specifically for gimp:

apt-get install gimp

Also, what is the output of

apt-get check


apt-get install -sf


Regards,            | http://users.icfo.es/Florian.Kulzer
          Florian   |

Reply to: