[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Updated Sid today, xorg cannot find "nvidia" driver

On 4/21/07, BartlebyScrivener <bscrivener42@gmail.com> wrote:
But I had a similar issue after a routine Etch update.  I found the
answer by following this:


error message was FATAL module Nvidia not found

The problem is that it worked this morning, but does not work this
afternoon, after "apt-get update ; apt-get upgrade" that didn't
include the Nvidia drivers. I looked first, since I have always
compiled my own nvidia driver since 2003 on this machine.


Except for including "nvidia" in /etc/modules, the instructions given
are what I did. Oh, but to compile I followed the instructions in
/usr/share/doc/nvidia-kernel-source/README.Debian, which does not use
Module Assistant.

I've also done it with Module Assistant, and it has worked both ways
in the past.

So I loaded the module by hand first,

# rmmod nvidia
# modprobe nvidia
NVRM: loading NVIDIA Linux x86 Kernel Module  1.0-8776  Mon Oct 16
21:56:04 PDT 2006

# /etc/init.d/kdm restart

and the error messages in /var/log/Xorg.0.log are (forgive me, typing
in by hand)

(II) LoadModule: "nvidia"
(WW) Warning, couldn't load module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)

Well, as you can see, something is very confused. I have no idea what
changed this morning, certainly the versions on the nvidia kernel
driver and nvidia-glx are the same, which was my first concern and has
happened in the past.

Still stuck,


Reply to: