[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Making hotplugging my camera work

Alan Chandler(alan@chandlerfamily.org.uk) is reported to have said:
> On Saturday 30 December 2006 19:32, Paul E Condon wrote:
> > On Sat, Dec 30, 2006 at 10:04:01AM +0000, Alan Chandler wrote:
> > > Can someone explain the processes that occur when I hot plug my
> > > camera in and kde pops up a dialog asking whether I want to
> > > download to digiKam, or open in a new window.
> ...
> > I'm not an expert, but this may help:
> > Cameras handle off-loading pictures in two different ways. The more
> > fancy cameras have special proprietary protocols for data transfer,
> > and give the user/owner special control options, but they require
> > specialized software. Less expensive cameras simply fake a $soft FAT
> > file system and let you use the file copy functions of your computer
> > to grab the pictures. Part of digikam is a collection of cloned
> > drivers for the expensive cameras.
> You misunderstand my question.
> I understand all that.  However, when I plug my camera in, KDE pops up a 
> dialog box saying new hardware found what you you like to do.  One 
> choice is to use digikam.
> In the past when this has happened (with cameras which emulate usb mass 
> storage and therefore do not need special drivers) digikam has put up a 
> dialog box with thumbnails of all pictures in the camera, and an offer 
> to select and download these into an album.
> With my new camera (which has this same support) it fails whilst trying 
> what show pictures it has in the camera.  The udev-hal-dbus chain is 
> not working correctly because the mount point /media/sdg1 does not seem 
> to have been created.
> Furthermore - when I try and use udev to make the camera device 
> have /dev/camera as its device, kde's dialog box pops up the first time 
> after a reboot when I plug the device in, but not again when I unplug 
> it and plug it in again.  If I do not have a udev rule to alter things 
> it does pop up a dialog box every time.
> In order to debug and track down what is not working, I am asking how 
> the udev-hal-dbus chain interacts with kde and digikam, and where to 
> look for configuration parameters so I can figure out what is not 
> working due to configuration problems and what might be a bug in kde 
> (or hal ...).

This may not apply to you, as you didn't say what version of digikam or
Debian, your running, but I have a problem like yours with version 
0.9.0~beta3-3 of digikan on a testing box.

Prior to this version it found, and used, my Kodak CX-4230 without any
problem.  Now it can't access it.

As I got my wife a new Qlympus FE-130 for Xmas, I tried to see if this
version worked with it, and it didn't, so I booted my Sid box which
uses digikam_2%3a0.8.2-3_i386.deb.  It does not yet, handle the
Olympus, but the Kodak is again working as usual on this version of

I have noticed that, in almost every new version of digikan, something
that worked before, doesn't in the new version.  So much so that I am
trying to find something to replace it and had not used it for months,
prior to getting the Olympus.  

:-) HTH, YMMV, HAND & New Year :-)

DOS Tip #2: Add BUGS=OFF to your CONFIG.SYS

Reply to: