[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Making hotplugging my camera work

On Sunday 31 December 2006 02:02, Wayne Topa wrote:

> This may not apply to you, as you didn't say what version of digikam
> or Debian, your running, but I have a problem like yours with version
> 0.9.0~beta3-3 of digikan on a testing box.

I am running debian SID
> Prior to this version it found, and used, my Kodak CX-4230 without
> any problem.  Now it can't access it.
> As I got my wife a new Qlympus FE-130 for Xmas, I tried to see if
> this version worked with it, and it didn't, so I booted my Sid box
> which uses digikam_2%3a0.8.2-3_i386.deb.  It does not yet, handle the
> Olympus, but the Kodak is again working as usual on this version of
> digikam.

Yes - same version as me

My Olympus C-745UZ works fine using the mass storage driver.

> I have noticed that, in almost every new version of digikan,
> something that worked before, doesn't in the new version.  So much so
> that I am trying to find something to replace it and had not used it
> for months, prior to getting the Olympus.

My Casio is one that is of the USB mass storage type (ie it doesn't need 
a special driver). If I set things up manually that works fine.

What I am talking about is the automatic recognition when you plug them 

I know this thread is drifting towards the photo packages on kde or 
gnome, but I suspect the problem could be with the interaction with 
udev/hal and the application.

Somewhere (and this is what I am finding hard to find) hal should have 
the device properties for the camera.  It should know its a camera and 
that its has storage of type mass storage.

Yet - if I do 

lshal | grep 'camera'

when the camera is plugged I don't get any lines that match.  That seems 
wrong - indeed, I sort of expect behind the scenes for hal to mount the 
device on /media/camera (or something similar - perhaps /media/sdg1, 
since /dev/sdg1 is the camera's picture partition).

On the otherhand - kde knows to suggest digikam as a potential 
application, so its getting the fact it is a camera from somewhere

There seems some random hal policy file in /etc/hal and some more what 
looks like configuration files in /usr/share/hal

But I cant find any information about which is the right place for me to 
add the information about 

> :-) HTH, YMMV, HAND & New Year :-)
> Wayne
> --
> DOS Tip #2: Add BUGS=OFF to your CONFIG.SYS
> _______________________________________________________

Alan Chandler

Reply to: