[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: update messages

On Thu, Dec 28, 2006 at 11:14:23PM +0000, Digby Tarvin wrote:
> On Thu, Dec 28, 2006 at 02:45:56PM -0800, Andrew Sackville-West wrote:
> > > Is that last line what is needed to get aptitude back into
> > > sync? If not, how is that achieved?
> > 
> > no, it won't. there are a variety of ways to do this. I prefer the
> > method below where you watch for problems and fix them as they
> > appear. There are several threads on this int he recent archives that
> > detail other methods of solving this problem (I think they essentially
> > mark *everything* as manual).
> Ah, ok. I'll guess I will just have to keep an eye on what aptitude
> says it wants to do and intervene if it isn't what I want...
> I think it was my initial ignorance of the problems of mixing
> apt-get and aptitude that lead to my initial inability to
> understand why aptitude wanted to do what it threatened to
> do, so I am glad I asked...

seems to be a common problem.

> > > > > Then I can try running aptitude and hopefully it will have stopped
> > > > > crashing and can tell me what else it thinks is left to be done....
> > > > 
> > > > I missed the bit about it crashing. what's happening?
> > > 
> > > It only started happening after I had tried an 'apt-get install aptitude'
> > > to upgrade to the latest version (and co-incidentally after I had done
> > > the 'apt-get install' of the pgp keyring - so I am not certain which
> > > was responsible).
> > > 
> > > What happens now is that after any attempt to issue a 'u' command in
> > > aptitude, I get an abort leaving me back in the command line (with a
> > > garbled display) and the error message:
> > >  aptitude: symbol lookup error: aptitude: undefined symbol: _ZN9pkgPolicyD2Ev
> > 
> > yuck. that sounds like a bug. does it do the same from command line?
> > 
> > aptitude update
> Not sure, but the 'apt-get upgrade' which just finished seems to
> have fixed it - whew!.

see Joey's message. yay! one down!

> I'm still stuck with the big red warning box complaining about the
> missing public key for multimedia.org after an update, and I'm still
> not clear if this is normal and expected (which would be annoying), or
> something specific to me (which would be worrying).
> If it is the former, I would have thought it would be better to
> just have some way of just not signing packages rather than signing
> with a key that can't be checked. 

so this is really a minor problem. basically, it prevents you from
knowing for sure that you're getting the right, uncorrupted
packages. you can solve this problem later.

> Anway, guess its time to hold my breath and see if the system
> still boots after the initial upgrade...

go baby go!


Attachment: signature.asc
Description: Digital signature

Reply to: