[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Printing from Acrobat

On Thu, Jul 27, 2006 at 13:17:41 -0400, Carl Fink wrote:
> On Wed, Jul 26, 2006 at 04:29:31AM +0930, Arthur Marsh wrote:
> > See my previous "fun" with CUPS and KDE in a few different bug reports.
> > 
> > Running Sid, I had to comment out the line in /etc/cups/cupsd.conf:
> > 
> > #Listen /var/run/cups/cups.sock
> > 
> > then restart CUPS in order for my local printer to be visible under 
> > KDE's printers, and after setting the CUPS printer as the local default 
> > there, all was well.
> Didn't help me, though.
> Problem maybe identified.  When I tried pdf2ps, it complained that the Arial
> font should have been embedded, but wasn't.  Of course this can't be a
> problem on modern Windows boxes, because they come with Arial.  Maybe I just
> need to learn how to alias some Helvetica-like font to "Arial" for xorg
> (which I have no idea how to do).
> Of course, in reality all I have to do is print the document from my
> Windows-running laptop, but this isn't a good thing for Debian.  And I have
> no idea how someone on this list printed the file using Sid.  Do you have
> Arial as an alias somewhere?

It should be enough to install the package "msttcorefonts" which is in
contrib. It will give you Arial, Times New Roman and a few other MS
fonts. (MS made these fonts available when they still tried to pretend
not to be a ruthless monopoly. They have not been updated in years, but
the license allows anyone to distribute them in the original format,

> While writing this I wanted to try to print again, but I noticed that CUPS
> is now not running?  So I tried to restart it, but it refuses to start--when
> I run "/etc/init.d/cupsys start" it prints the last page I printed yesterday
> (?) then exits with no error message in /var/log/cups/error_log.

Did you try purging all cupsys packages and reinstalling them? I think
there were a few cases recently where old cups config files screwed up
the new version of CUPS.


Reply to: