[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: copying a 12GB file

Michael Gregg wrote:

I very well may be a problem with NFS itself, and I'd like to know what
it is if you ever figure out the problem.

I'm sorry, but I'm probably not very helpful with that. I just installed an ftp server to copy the file which went flawless at work. My setup at home involves an outdated installation, so it isn't suitable for bug hunting ...

Have you tried directly connecting together the two machines that are
having problems?

No, the x-wires I have are too short for that, and it would have made the mailserver unreachable for the users.

Have you done tcpdumps on the links that the machines exist on?


Once I tried out tcpdump, and it yields lots of data with which I can do nothing.

> Are you
getting any collisions on the network links?

None that I know of. There have been some complaints about slow network speed during the transition from the old 10Mbit switches to the new ones, and my idea was that having 10Mbit switches and a significant amount of 10Mbit clients on the network, together with 100 and 1000Mbit stuff, is a combination that may introduce problems with network speeds. After the transition was completed, there were no more complaints. Overall network speed is fine now :)

What network cards do you have in the machines that you are dealing

Onboard cards:

Ethernet controller: Broadcom Corporation NetXtreme BCM5702X Gigabit Ethernet (rev 02)
nVidia Corporation CK804 Ethernet Controller (rev a3)

At home, it's a 3Com 3c509 and another NVIDIA, probably the same type. But IIRC, I tried it on two of the 3Coms and only later switched to the onboard card. I tried to copy over a number of files, about 550M in total, and the server I copy to freezes during copying.

Thus, I just consider NFS as deprecated.


Reply to: