[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dhcp client wifi setup

Richard Lyons wrote:


I found that too, and tried "modprobe ieee80211_crypt_wep" The module
loaded but the connection still obstinately failed.  I found two other
modules in /lib/modules/2.6.14-2-686/kernel/net/ieee80211/, namely
ieee80211_crypt_ccmp and ieee80211_crypt_tkip, so I modprobed them too,
but that did not help either -- I expect they are for hardware I do not
have anyway.

Well, I have one last suggestion to make: Check with lsmod if the
orinoco driver is actually using the ieee80211 modules. On my laptop the
relevant output looks like this:

florian@isar:~$ lsmod | grep ieee80211
ieee80211_crypt_wep     4992  1
ieee80211              23752  1 ipw2100
ieee80211_crypt         5636  2 ieee80211_crypt_wep,ieee80211

I think you should see something similar with "ipw2100" replaced by
the name of your wireless driver. Note also that the ieee80211_crypt_wep
module is used by one other module; the fact the name of this module is
not given probably means that it is compiled statically into my
(self-built) kernel. If you see a "0" there it means that the wep-module
is not used at all; maybe there is at least one other module which you
need to load.

After looking at the 2.6.14 kernel sources I would suggest that you try
to modprobe the following modules:


If one of these does not fix the problem it is probably time to talk to
someone with specific knowledge about the orinoco drivers; maybe there
is a certain trick which has to be used with WEP or the order in which
the modules are loaded is important. It might be worthwhile to ask for
further help on the debian-laptop list, with a short summary of what we
have tried so far and a subject like "orinoco wireless with WEP under
kernel 2.6.14-2-686". (Not everyone reads debian-user and an "orinoco
specialist" might have overlooked the present thread due to its
dhcp-centered subject.)

Good luck,

Reply to: