[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dhcp client wifi setup



On Sunday, 25 December 2005 at 13:15:45 +0100, Florian Kulzer wrote:
> Hi again,
> 
> Richard Lyons wrote:
[...]
> 
> >eth0      IEEE 802.11b  ESSID:"Coixxxxxxxxx"   Nickname "HERMES I"
> >          Mode:Managed  Frequency:2.422 GHz  Access Point: Not-Associated
> 
> I think that is the cause of your problem: Your interface does not
> associate with the access point even after you set the ESSID
> and the KEY.  (Otherwise we should see "Access Point: XX:XX:XX:XX:XX:XX"
> with the X's being the MAC address of your router.) We have to fix this
> and then the dhcp-client should be fine.
[...]
> >
> >Kernel is 2.6.14-2-686 
[...]
> 
> I have downloaded the headers for this kernel and it seems to me that
> the ieee80211 drivers are always compiled as modules rather than
> statically included in the kernel. (If you post the output of "grep -i
> ieee80211 /boot/config-2.6.14-2-686" we can know for sure.)

As you surmised:
castagna:~# grep -i ieee80211 /boot/config-2.6.14-2-686
CONFIG_IEEE80211=m
# CONFIG_IEEE80211_DEBUG is not set
CONFIG_IEEE80211_CRYPT_WEP=m
CONFIG_IEEE80211_CRYPT_CCMP=m
CONFIG_IEEE80211_CRYPT_TXIP=m

> I suspect that the module ieee80211 is not loaded and that therefore
> your wireless interface does not know how to "speak WEP". Check the
> output of "lsmod | grep -i ieee80211". If that comes up empty, try to
> "modprobe ieee80211" as root to load the module. If that works without
> error messages you can check if the interface associates with the access
> point now and then try to ifup it again. 

Nearly!  You were right that the modules were not loaded.  I tried
'modprobe ieee80211' and 'ifup eth0' and also rebooting after editing
/etc/modules. It now loads two modules ieee80211 and ieee80211_crypt.  
I assume that is the expected outcome.  
It still does not associate automatically, but if I
manually 'ifconfig eth0 essid...' and 'ifconfig eth0 key...' and then
'ifup eth0', then ifconfig eth0 shows the 'Frequency:' and 'Access Point:' 
for the router correctly.  But still ifup eth0 fails to get an offer.

(BTW, I tried several iterations, and on one occasion, iwconfig failed 'No
such device' and I then found it had allocated wlan0 instead.  That did
connect either.  I think this is a red herring [=irrelevant and
confusing].)

I must be getting close.  iwconfig now shows, for example:
       ...Link Quality=18/92  Signal level=-79 dBm  Noise level=-97 dBm

Are those reasonable figures?

Thanks for the help so far -- and on xmas day!

-- 
richard

Happy newtonmas/xmas/chanukka/new-year/sylvester/etc!



Reply to: