[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dhcp client wifi setup

On Tuesday, 27 December 2005 at  2:13:22 +0100, Florian Kulzer wrote:
> Richard Lyons wrote:
> [...]
> >Nearly!  You were right that the modules were not loaded.  I tried
> >'modprobe ieee80211' and 'ifup eth0' and also rebooting after editing
> >/etc/modules. It now loads two modules ieee80211 and ieee80211_crypt.
> >I assume that is the expected outcome.
> >It still does not associate automatically, but if I
> >manually 'ifconfig eth0 essid...' and 'ifconfig eth0 key...' and then
> >'ifup eth0', then ifconfig eth0 shows the 'Frequency:' and 'Access Point:'
> >for the router correctly.  But still ifup eth0 fails to get an offer.
> I think it is normal that the wireless interface only associates with
> the AP after the key and the essid have been set (if WEP is used and the
> router does not broadcast the essid). 

I found that I needed to do all three steps to get it to associate:

 1  iwconfig eth0 essid xxxx...
 2  iwconfig eth0 key xxxx-xxxx-xxx...
 3  dhclient (or ifup) eth0

After this, the access point is listed by iwconfig.

> module ieee80211_crypt_wep. Therefore I hope that "modprobe
> ieee80211_crypt_wep" is the missing piece of the puzzle.

I found that too, and tried "modprobe ieee80211_crypt_wep" The module
loaded but the connection still obstinately failed.  I found two other
modules in /lib/modules/2.6.14-2-686/kernel/net/ieee80211/, namely
ieee80211_crypt_ccmp and ieee80211_crypt_tkip, so I modprobed them too,
but that did not help either -- I expect they are for hardware I do not
have anyway.

So, in fact, I seem to have exhausted the possibilities and still have
no improvement.  Maybe the hardware is faulty, though it is surprising
that it would work without WEP if so.

Anyway, thanks again.  I'll just have to stay wired.
> >       ...Link Quality=18/92  Signal level=-79 dBm  Noise level=-97 dBm

> That looks good to me, you are almost 20 dBm above noise. My own ipw2100
> functions reliably down to a signal level of about -86 dBm, so you
> should be fine. However, if your problem persists it might be worthwhile
> to try to explicitly set the sensitivity threshold very low, e.g.
> "iwconfig eth0 sens -85". 

Since it works without WEP, I do not think this can be necessary.

Best wishes for 2006 to everyone.


Reply to: