[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X won't start having upgraded from xsever to xorg

Antony Gelberg on 14/09/05 10:00, wrote:
Tong Sun wrote:

This is a real emergency. My X won't start now, having
upgraded from xsever to xorg.
Is there any way I can have my X back?
I saw in thread
Routine upgrade of packages tracking etch has hosed

that there is way to restore using xserver instead of
xorg. I tried to follow it, but wasn't successful.
I removed all xorg and xserver packages and reinstall
xserver from scratch, but still I was forced to
install xorg.
I installed the xorg, try its hardware auto-detection,
again, but still my X won't start. The sypmtom is,
still, the screen gets into graphic mode, with garbage
on it, and the whole system just freeze. I tried
Ctrl-Alt-\, Ctrl-Alt-F?, Ctrl-Alt-Del, nothing worked.

Please help. It's a real emergency, and I'm desperate.

Is there any way, any?

Use Debian stable. If you can't handle package balls-ups, it's really not a good idea to run testing or unstable.

Hi there, just jumping in.

Months back, I installed Sarge.

Then in synaptec last week I did an upgrade of everything that was upgradeable. Brave and foolish with my experience, yes, but it worked, but I was having problems with gnome and wanted to sort it.

Now at my login prompt, it says I have Unstable/Testing and it swapped my XFree86 for X.org.

And I didn't change anything in my sources file.

So I was more or less lead astray just by trying to keep up-to-date, while trying to be sensible.

So pity the poor OP. Maybe he/she never intended to move off Debian Stable.

Reply to: