[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help with broken Aptitude

On Thu, Jun 30, 2005 at 10:33:34AM +0100, Bryan Jackson wrote:
> Hello everyone.  I have lurked on this group for a while but this is my
> 1st post.


> I have a Debian Sarge box that was working fine until Sarge went stable.
>  Aptitude has started acting very strange,  in fact apt in general
> seems broken.  The symptoms are as follows.
> 1.  I have had no upgrades when when I run "aptitude update, aptitude
> upgrade" since sarge went stable.

Always a good idea to 'aptitude update' before installing, upgrading -
keeps everything in sync.

> 2.  When trying to install a package from the command line using
> aptitude install <package> I get a "No installation cantidate" error.
> example:
> violator:~# aptitude search apt-file
> p   apt-file                                   - APT package searching
> utility -- command-line interf
> violator:~# aptitude install apt-file
> Reading Package Lists... Done
> Building Dependency Tree
> Reading extended state information
> Initializing package states... Done
> Reading task descriptions... Done
> No candidate version found for apt-file
> No packages will be installed, upgraded, or removed.

What's the output of 'apt-cache policy apt-file'?
> My sources.list
> deb http://security.debian.org/ sarge/updates main contrib non-free

No security updates for 'contrib' or 'non-free'

'deb http://security.debian.org/ sarge/updates main' is all that is

> deb ftp://ftp.uk.debian.org/debian/ sarge main non-free contrib
looks ok


Reply to: