[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solved (was Re: CUPS remote printing problem)

I (Marty) wrote:
I have an HP PSC 2110 working locally with foomatic and CUPS back end.
When I try to print remotely the CUPS web interface returns with:

"Print file was not accepted (client-error-bad-request)!"

I find these entries in /var/log/cups/error_log:

E [01/Jul/2005:00:13:09 -0400] print_job: No file!?!
D [01/Jul/2005:00:13:09 -0400] send_ipp_error(0x403b7008[5], 400)
D [01/Jul/2005:00:13:09 -0400] Sending error: client-error-bad-request

I can print to another system with CUPS/IPP (non HP) printer on the
same network.  I tried to remotely print to the HP from a second system
and hit the same problem.

A google search indicates it might be an hpijs/gs interaction, so I
tried different versions of gs without success.  The solution in the
archived message was to switch drivers, but that was for a woody install.

Thanks for any help.

My remote system was missing these packages: libijs-0.35, foomatic-db-hpijs,
and hpijs.  I had mistakenly assumed apt would handle all relevant dependencies,
but apparently this is not the case and CUPS itself does no sanity checking.

I now interpret the error messages as indicating a "raw job" resulting from
the lack of a complete foomatic install. The lack of error reporting on the
remote side is a bit puzzling, although I had forgotten to turn on debug
logging there so it's possible it would have been flagged.  It seems like a
more "in your face" warning or even error message would have been appropriate.

FWIW I suspect that my use of the CUPS server-server model, instead of the
client-server model is a factor here, requiring the complete set of printing
packages.  On a side note, I was one of the many who apparenly are unsuccessful
setting up the CUPS client-server model.  It seems that most users who report
problems default to the server-server model, which seems much simpler to set
up at the cost of a little more disk space.

Reply to: