[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: LILO bug?

Alvin Oga wrote:

On Fri, 1 Jul 2005, Marty wrote:

In addition to the SCSI disk becoming unbootable -- the SCSI drive LED
flashed when LILO wrote to it; and pulling the SCSI cable (not recommended)

just because the light flashed doesnt mean it was written

True, but in combination with the other evidence, it's pretty clear that
LILO wrote to the SCSI disk.  I have no alternate explanation.

As I mentioned before, the target partition /dev/hda1 subsequently failed to
boot, and removing the SCSI disk from the system bypassed the entire problem.

failing to boot is NOT the same problem as problems with lilo.conf of lilo

See above.

I don't know offhand how to map the BIOS disk numbers (0x80, 0x81, ...)
to the Linux disk numbers (0x300, 0x301, ...).

which may explain why you have wierd behavior if you did try those whacky disk reassignment commands in lilo

That solution attempt happened after the problem appeared.  It's one
of many solutions I've tried.

As I pointed out before, I don't get as far as booting.  The target drive
hda still doesn't boot and the SCSI drive stops booting.

you can boot ... anything ... even w/o "/" mounted ... you'd just get
kernel panic or  "/" ( aka init ) not found

booting sequence has nothing to do with the rootfs

IIRC in the case of /dev/hda1 the BIOS finds no bootable disk,
and in the case of the SCSI drive it fails to find the kernel.

> 	- label theboot kernel differently, explicitly for each
> 	hard disk

See above.

a super important detail that you will need to do.. to prove that
you can boot from /dev/hda or from /dev/sda

	hda  --->>
		label = hda-vmlinuz

	sda --->
		label = SDA-vmlinuz

than see what is booting .. or attempting to boot

I prefer to use the BIOS to select the boot/root drive and it works fine.

> - it's NOT possible, or extreme slim chance, lilo writes to the wrong
>   boot=/dev/xxx divice

The impossible seems to be happening.  I'd entertain alternate theories.

usually lilo and grub problems are misconfigured files ...
	or "dirty" mbr that havent been cleaned up yet

But even a "dirty MBR," if I had one, should not cause LILO to write to the wrong disk.

I've seen it many times on different systems, hence the workaround.  I don't know
if others can duplicate it or not, hence one of the reasons for posting.

i do NOT wsee any problems with lilo or grub with ide vs scsi disks
	- and you named it... i probaby get whacko trying to boot it

I think I've seen the problem on an IDE-only system too.

Thanks for your input but there may be no point in tying up more list
bandwidth.  I'll probably just go ahead and file the bug report.

Reply to: