[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

resolv.conf [Solved!]

On 30/06/05, Craig Russell <craig@airdigitalnetwork.com> wrote:
> Ok-
> Never used pppoe with debian, but, in reading the man page and the files
> in /usr/share/doc/pppoe it appears that the client side program can
> either be run from the user-space or be loaded directly into the
> kernel.  If this started happening after you upgraded to sarge, my guess
> is that you are attempting to load this twice.  Look through the scripts
> in /etc/init.d and find any references to ppp in them; see what is being
> called.  The other thing to look at is the ppp config files in /etc/ppp
> to see what is being configured their.  If you have configuration
> parameters in /etc/network/interfaces AND /etc/ppp that could also be
> causing your problem.
> Somethings to look at.
> Good Luck
> Craig Russell
> AirDigitalNetwork.com

Well, after peering through many files and scripts and a whole lot of
things, I have FINALY! discovered the problem and rectified it.

The Situation (for the record):

Using pppoeconf to configure my DSL pppoe connection and asking it to
connect at boot-up, it was creating two connections: PPP0 (the right
one) and PPP1 (an extra, un-wanted, heretical and hethenous one). In
lieu of giving

# ifconfig ppp1 down

every time and having to wait the extra seconds at boot-up, I managed
to find some thing: ppp-on-boot.dsl and the link file ppp-on-boot.
After deleting these two files, and configuring the
/etc/network/interfaces (which had actually already been done...
odd....) my internet is alive, well and single.

Thanks to the Debian Community for another solved problem.

Reply to: