[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Firefox no print issue

Nicos Gollan wrote:
On Saturday June 4 2005 03:28, Jim Hall wrote:

Results of suggestions.
Tried the Postscript entry; same bad result.
Looked for all pkgs related to xprint. Found: xprt-xprintorg, xprint,
xprint-common. When I tried to remove them, that would also remove
x-window-system! That seems like xprint is a necessary component and
can't be separated from X.

x-window-system is just a metapackage (a bunch of dependencies) that can be removed without any worries.

So, if cups is the system default why did xprint stick it's nose into
Firefox's business? If I can't remove xprint, is there any way to change
it? Or, is this a Firefox problem, since no other app seems to be affected?

It's a Mozilla problem. Xprint is an initiative that spawned from the Mozilla project. It's basically a translator that converts the X protocol to Postscript. Also, it's pretty telling that the version in Debian is 0.1.0.alpha1-10, with no corresponding release being offered by the project itself. It might get better with a transition to X.org which Xprint seems to have become a part of.

Per the above info I removed xprint, which also took xprt-xprintorg, xprint-common, and x-window-system. Nothing seems to have blown up. :)

Still have the same error at the printer. In Firefox, the only printer listed is now "PostScript/QMS1660".

In the Printer Properties dialog box the "Print Command" is:

Because printing in Linux and I are not on the best of terms, I sort of expected to see something more CUPS related. I say that because in the CUPS setup I've done so far I didn't see any lpr commands.

What's next?

Reply to: