[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Firefox no print issue

Nicos Gollan wrote:
On Friday June 3 2005 04:40, Jim Hall wrote:

Web site page in Firefox. Go to File -> Print -> dialog box. Click
"print" button: page is sent to printer, first page is a PS error, lots
of blank pages follow.
The printer is listed as: QMS 1660@:64.

This looks like you're using xprint to print from Firefox. Don't use it, xprint is buggy as hell. The printer should be listed twice, once as "QMS 1660@:64" as you said, and then again as "PostScript/QMS 1660". Try printing from the "PostScript/..."-entry. If this works, find all installed packages that have xprint in their names and deinstall them.

This way, you'll lose some settings in Firefox's print setup (e.g. duplex print if it's available at all), but at least it should work with the printer's default settings.

Results of suggestions.
Tried the Postscript entry; same bad result.
Looked for all pkgs related to xprint. Found: xprt-xprintorg, xprint, xprint-common. When I tried to remove them, that would also remove x-window-system! That seems like xprint is a necessary component and can't be separated from X.

So, if cups is the system default why did xprint stick it's nose into Firefox's business? If I can't remove xprint, is there any way to change it? Or, is this a Firefox problem, since no other app seems to be affected?


Reply to: