[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need Help-YMF724F Sound Card And ALSA

On Sunday 17 April 2005 08:54, you wrote:
> Justin Guerin wrote:
> >Copying the list, so others might be able to help
> >
> >On Saturday 16 April 2005 18:49, you wrote:
> >>Justin Guerin wrote:
> >>><posted & mailed>
> >>>
> >>>Leonard Chatagnier wrote:
> >>>>Have tried for several weeks to get sound from my Dell Dimensions XPS
> >>>>T450 with YMF724F sound
> >>>>card and ALSA drivers. snipped ...
> >>>
> >>>I used to have a Dell XPS T450 with YMF724 sound, and it worked
> >>> perfectly. So it's possible.
> >>
> >> snipped
> >>
> >>>>effort followed the instructions at
> >>>>www.alsa-project.org/alsa-doc/doc-php/template.php?module=ymfpci#opt
> >>>>with no resulting sound from my pc.  Using alsamixer, I unmuted all and
> >>>>set volume controls up to
> >>>>90% on everything; still no sound.  Googling yielded lots of hits but
> >>>>nothing useful except the above
> >>>>URL.  I'm using real player 10 GOLD and can play video news clips from
> >>>>Reuters and API on MyYahoo
> >>>>with good video output but no sound.  I do get static from my speakers
> >>>>after setting the alsamixer so I'm
> >>>>confident the speakers are wording.  ymfpci module is loaded.  I ran
> >>>>update-modules after following the instructions at the above URL.
> >>>>Hopefully someone using the YMF724F card can tell me what is wrong and
> >>>>how to fix it, but would appreciate any help whatsoever.  My ALSA
> >>>>related modules.conf is listed below:
> >>>
> >>>[snip modules config]
> >>>
> >>>>I also tried to set up the*_The .asoundrc file__snipped...
> >>>>Len Chatagnier
> >>>>*
> >>>
> >>> snipped: kept for my record
> >>
> >>Thanks for this info; I couldn't find or maybe overlooked this info when
> >>reading the
> >>man page for vi(vim).  Since the .asoundrc file only enhances,  I'll try
> >>creating the file
> >>when I have sound.
> >>
> >>>Anyway, on to your problem.  Did you run aslaconf?  That should be able
> >>> to set up your sound card for you.  You will then need to run alsamixer
> >>> to unmute the channels.
> >>
> >>Thanks, for your replying.  Yes, have run alsaconf and alsamixer twice
> >>but still
> >>no sound while video plays beatifully.  Even tried gamix a coulple of
> >>times.  Everything
> >>set up to 90% or better volume.  The last time run alsaconf, it
> >>eliminated the dev/dsp
> >>artsinformational error message that said "too many links to resolve" or
> >>something to
> >>that effect.  Some progess indicated, maybe?  This message popped up
> >>everytime I started
> >>KDE GUI.  Hope I didn't initialize something that would prevent sound
> >>from playing when
> >>using the mixers through my ignorance.
> >
> >snipped...
> >
> >"Too many links to resolve" is an interesting error message that I've not
> >seen.
> Related to this, when I last ran alsaconf, video stopped playing on real
> player giving a message
> similar to: non-recognized media format, run change media setting and
> make sure you have the
> proper plugins.  Control center was set to autodetect so I changed it to
> OSS and the video started
> playing again, then went to ALSA and it still played video, no sound,
> and left
> it on ALSA.  This also brought back the artsinformational message about
> too many open links on /dev/dsp.
I did a little research on the too many open links problem, and it seems to me 
that you've got recursive links.  Can you post the output of ls -l /dev/dsp, 
and the output of ls -l of every file that original link points to?  I have a 
feeling after one or two steps, it will point back to /dev/dsp, which is a 
bad thing.

> >>>You mention that you've been using real player to test the sound.  How
> >>>about using something a little more basic, like a command line utility
> >>>(play, for example).  That might give you a more meaningful error
> >>>message.
> >>
> >>After reading the help files for play and sox, did this with results
> >> shown: ChatagnierL-Home:/home/lchata# play
> >> /usr/lib/games/luxman/11k/siren.snd playing
> >> /usr/lib/games/luxman/11k/siren.snd
> >>sox: Failed reading /usr/lib/games/luxman/11k/siren.snd: Did not detect
> >>valid Sun/NeXT/DEC magic number in header.
> >>ChatagnierL-Home:/home/lchata#
> >>
> >>Also did the same file at 8K with same sox message.  Played a different
> >>8K file with same results.
> >>If I needed to specify an option, didn't because they are greek to me.
> >
> >This error message indicates that the file you are attempting to play is
> >corrupt.  It's not a valid sound file, and even if your sound worked
> >perfectly, you wouldn't be able to play it.  Do you have any known good
> > sound files to work with?
> >
> >Unfortunately, this error is detected before play attempts to open your
> > sound device and play the file, so it doesn't tell us anything about
> > whether or not your sound is configured.
> >
> >>>Are you using a sound daemon, like arts or esd?  If so, is real player
> >>>configured to play through the sound daemon?  Snipped...
> >>
> >>I believe I'm using artsd, but havent' restarted it lately.  snipped....
> >
> >If you're logged in to KDE, odds are you're using artsd.  You can find out
> > for sure by running "ps ux | grep arts", and if you see a line like this:
> > justin    5404  0.0  2.0  57264  5340 ?        S    Mar27   5:57 artsd -F
> > 10 -S 4096 -a alsa -s 10 -m artsmessage -c drkonqi -l 3 -f
> >then you're definitely using arts.  Alternately, you can open up the KDE
> >control center, then open the "sound and multimedia" section, and click on
> >the sound system module.  If "Enable the sound system" is checked, then
> >you're using arts.  You might try hitting the test sound button, to see if
> > it provides any good feedback.
> Artsd is running as shown:
> lchata@ChatagnierL-Home:/etc$ ps ux | grep arts
> lchata    3503  0.8  5.7 21164 7312 ?        S    12:35   0:00
> /usr/bin/artsd -F 10 -S 4096 -a oss -s 60 -m artsmessage -c drkonqi -l 3 -f
> lchata    3513  0.0  0.3  1548  468 pts/1    S+   12:37   0:00 grep arts
> lchata@ChatagnierL-Home:/etc$
> Also, the enable sound system was checked in control center and playing
> the test button gives me a beep but
> the sound is coming from a builtin modem speaker not from my HP
> polleaudio sterio speakers I have hooked up.
> The modem has always worked for system sounds.  Note: could be the
> speakers are not plugged in correctly; however, I checked the icons on
> the recepticles and they appear to be correct.  Mic to Mic, speakers to
> output and a yellow plug tapped from my monitor plug going to input on
> the Dell machine as they were on the HP Pavilion 8370.  I don't have
> documentation on the Dell so can't be sure about hookup.
> >>>Post the sound related output of lsmod, and post the attempts at playing
> >>>sound with a command line utility, and that should help pinpoint the
> >>>problem.
> >>
> >>ChatagnierL-Home:/home/lchata# lsmod
> >>
> >>snipped: results ok
> >
> >You got enough for us to know that you've got the proper alsa related
> > sound modules loaded, and you've got oss emulation running, which means
> > "play" should work.  That's good.
> >
> >>>Justin Guerin
> >>
> >>Justin, thanks so much for your response.  I was beginning to panic and
> >>about to remove alsa and give oss a try.
> >>Hope the info provided pinpoints the problem.
> >>
> >>Leonard Chatagnier
> >
> >It helps, but unfortunately, we pinpointed a problem with the file you
> > were attempting to play, and not your sound setup.  If you can find a
> > known valid sound file, post the results of trying to "play" it.
> Searched sox media type extensions and attempted to play several as
> follows with results:
> ChatagnierL-Home:/home/lchata# play
> /usr/share/sounds/Kopete_User_is_Online.ogg
> playing /usr/share/sounds/Kopete_User_is_Online.ogg
> sox: Can't open output file '/dev/dsp': Too many levels of symbolic links
> ChatagnierL-Home:/home/lchata#
> Estensions cvs, ogg, mp3 all gave the above message.  snd gave the
> original message posted
> previously.  dat gave a message saying it could not determine the
> sampleing rate.
> Perhaps I should use some option in the play command?  I would be glad
> to download and
> play a known good media file if you could suggest one and the URl to
> locate it.  I think we're
> getting close.  For checkout purposes, should I leave KDE sound hardware
> settings on autodetect
> as it originally was, on ALSA or on OSS?  Also, if you have any
> suggestions on checking out the
> speaker, mic, monitor plugs from my HP accessories I'm using into the
> Dell machine, I'm more
> than wiling to take the time.
I think the files you tried to play that gave you the error about too many 
levels of symbolic links are good files.  Right now, that's the error you've 
got to fix.  

One way to do this is to move all alsa related config files out of the way, 
run alsaconf, and see if it still generates recursive links.  If it doesn't, 
you might be finished.  If it does, post the results, and what you did, and 
we'll work it from there. 
> >Justin Guerin
> Thanks for your much needed help.
> Leonard Chjatagnier
Sorry for the delay in my response.

Justin Guerin

Reply to: