[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need Help-YMF724F Sound Card And ALSA



Copying the list, so others might be able to help

On Saturday 16 April 2005 18:49, you wrote:
> Justin Guerin wrote:
> ><posted & mailed>
> >
> >Leonard Chatagnier wrote:
> >>Have tried for several weeks to get sound from my Dell Dimensions XPS
> >>T450 with YMF724F sound
> >>card and ALSA drivers.  Have posted before on this issue with no
> >>solution forthcoming.  My latest
> >
> >I used to have a Dell XPS T450 with YMF724 sound, and it worked perfectly.
> >So it's possible.
>
> Great.  Using alsa or oss?
>
It was probably OSS, since it was a few years ago, but honestly, I don't 
remember.  It could have been alsa.  I was also new to Linux, but for me, 
sound just worked.

> >>effort followed the instructions at
> >>www.alsa-project.org/alsa-doc/doc-php/template.php?module=ymfpci#opt
> >>with no resulting sound from my pc.  Using alsamixer, I unmuted all and
> >>set volume controls up to
> >>90% on everything; still no sound.  Googling yielded lots of hits but
> >>nothing useful except the above
> >>URL.  I'm using real player 10 GOLD and can play video news clips from
> >>Reuters and API on MyYahoo
> >>with good video output but no sound.  I do get static from my speakers
> >>after setting the alsamixer so I'm
> >>confident the speakers are wording.  ymfpci module is loaded.  I ran
> >>update-modules after following the instructions at the above URL.
> >>Hopefully someone using the YMF724F card can tell me what is wrong and
> >>how to fix it, but would appreciate any help whatsoever.  My ALSA
> >>related modules.conf is listed below:
> >>NOTE: Not subscribed-PLEASE COPY MY EMAIL ADDRESS.
> >
> >[snip modules config]
> >
> >>I also tried to set up the*_The .asoundrc file__
> >>_as shown in the above URL but am not familar with the vi command and
> >>couldn't figure how to
> >>save it.  I just closed the terminal and cated the .swp file which was a
> >>binary an appeared to have
> >>the copied data in it.  However, I don't think the .asoundrc file should
> >>have an .swp extension.
> >>Read man vi, but didn't understand it.  Again, I'd appreciate any help
> >>resolving this issue.
> >>Thanks,
> >>Len Chatagnier
> >>*
> >
> >To save in vi, first you need to enter command mode by hitting the escape
> >key.  Then, type :wq and hit return (<colon>wq<return>)  The binary .swp
> >file is how vi tracks the changes that you've made to the file.  It's not
> >going to be sufficient to copy the .swp file to the destination file.
> >However, the .swp file is there to save your edits, should vi crash for
> > any reason.  In that case, just vi the file again (not the swap file, the
> > original file), and vi will ask you if you want to recover your changes
> > from a previous session.
>
> Thanks for this info; I couldn't find or maybe overlooked this info when
> reading the
> man page for vi(vim).  Since the .asoundrc file only enhances,  I'll try
> creating the file
> when I have sound.
>
> >Anyway, on to your problem.  Did you run aslaconf?  That should be able to
> >set up your sound card for you.  You will then need to run alsamixer to
> >unmute the channels.
>
> Thanks, for your replying.  Yes, have run alsaconf and alsamixer twice
> but still
> no sound while video plays beatifully.  Even tried gamix a coulple of
> times.  Everything
> set up to 90% or better volume.  The last time run alsaconf, it
> eliminated the dev/dsp
> artsinformational error message that said "too many links to resolve" or
> something to
> that effect.  Some progess indicated, maybe?  This message popped up
> everytime I started
> KDE GUI.  Hope I didn't initialize something that would prevent sound
> from playing when
> using the mixers through my ignorance.
>
I can't think of anything you could do with a mixer that would prevent sound 
from playing, so don't worry about that.

"Too many links to resolve" is an interesting error message that I've not 
seen.

> >You mention that you've been using real player to test the sound.  How
> > about using something a little more basic, like a command line utility
> > (play, for example).  That might give you a more meaningful error
> > message.
>
> After reading the help files for play and sox, did this with results shown:
> ChatagnierL-Home:/home/lchata# play /usr/lib/games/luxman/11k/siren.snd
> playing /usr/lib/games/luxman/11k/siren.snd
> sox: Failed reading /usr/lib/games/luxman/11k/siren.snd: Did not detect
> valid Sun/NeXT/DEC magic number in header.
> ChatagnierL-Home:/home/lchata#
>
> Also did the same file at 8K with same sox message.  Played a different
> 8K file with same results.
> If I needed to specify an option, didn't because they are greek to me.
>
This error message indicates that the file you are attempting to play is 
corrupt.  It's not a valid sound file, and even if your sound worked 
perfectly, you wouldn't be able to play it.  Do you have any known good sound 
files to work with?

Unfortunately, this error is detected before play attempts to open your sound 
device and play the file, so it doesn't tell us anything about whether or not 
your sound is configured.

> >Are you using a sound daemon, like arts or esd?  If so, is real player
> >configured to play through the sound daemon?  If not, you may have
> > problems due to the device being locked by the sound server.
>
> I believe I'm using artsd, but havent' restarted it lately.  Being
> windows orientated
> and new to Debian, if debconf didn't configure it, neither did I.
>
If you're logged in to KDE, odds are you're using artsd.  You can find out for 
sure by running "ps ux | grep arts", and if you see a line like this: 
justin    5404  0.0  2.0  57264  5340 ?        S    Mar27   5:57 artsd -F 10 
-S 4096 -a alsa -s 10 -m artsmessage -c drkonqi -l 3 -f
then you're definitely using arts.  Alternately, you can open up the KDE 
control center, then open the "sound and multimedia" section, and click on 
the sound system module.  If "Enable the sound system" is checked, then 
you're using arts.  You might try hitting the test sound button, to see if it 
provides any good feedback.

> >Post the sound related output of lsmod, and post the attempts at playing
> >sound with a command line utility, and that should help pinpoint the
> >problem.
>
> ChatagnierL-Home:/home/lchata# lsmod
> Module                  Size  Used by
> pcspkr                  3592  0
> snd_ymfpci             61316  0
> snd_ac97_codec         69988  1 snd_ymfpci
> snd_pcm_oss            55080  0
> snd_mixer_oss          20096  1 snd_pcm_oss
> snd_pcm                98728  2 snd_ymfpci,snd_pcm_oss
> snd_opl3_lib           10656  1 snd_ymfpci
> snd_timer              25668  3 snd_ymfpci,snd_pcm,snd_opl3_lib
> snd_hwdep               9412  1 snd_opl3_lib
> snd_page_alloc         11752  2 snd_ymfpci,snd_pcm
> tsdev                   7392  0
> gameport                4704  1 snd_ymfpci
> snd_mpu401_uart         7968  1 snd_ymfpci
> snd_rawmidi            25124  1 snd_mpu401_uart
> evdev                   9600  0
> snd_seq_device          8200  2 snd_opl3_lib,snd_rawmidi
> snd                    57156  11
> snd_ymfpci,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_opl3_lib,sn
>d_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device soundcore      
>        10336  1 snd
>  Got everything I knew or thought to be sound related.  There are some
> module ID's that I don't know what they refer to.
>
You got enough for us to know that you've got the proper alsa related sound 
modules loaded, and you've got oss emulation running, which means "play" 
should work.  That's good.

> >Justin Guerin
>
> Justin, thanks so much for your response.  I was beginning to panic and
> about to remove alsa and give oss a try.
> Hope the info provided pinpoints the problem.
>
> Leonard Chatagnier

It helps, but unfortunately, we pinpointed a problem with the file you were 
attempting to play, and not your sound setup.  If you can find a known valid 
sound file, post the results of trying to "play" it.

Justin Guerin



Reply to: