[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ALSA -sound

> > Any suggestions please.
> First check that you have the relevant module. It should be here:
> /lib/modules/[kernel-version]/kernel/sound/pci/ali5451/snd-ali5451.ko
> If it's missing, you'll need to compile it from source or install a
> new kernel.
> If the module exists, what are the results of
>         $ lsmod | egrep "snd|sound"
> ?
> If you don't see "snd-ali5451", try
>         # modprobe snd-ali5451

If snd-ali5451 is compiled in static, lsmod will not return anything.
I have the same card, compiled in static and everything works.
alsaconf doesn't work here either (don't bother). Since you can listen
to CDs, it is evident that the setup is working.  You do not need oss
modules, but you do need alsa oss emulation, which I believe you have
already compiled in.

I do not believe that your sound issues with mozilla and mp3 are
kernel related, however I could be wrong. My .config for is
available here, http://gpoppy.org/config- in case you need to
check. This config works fine on Compaq Presario 2540 ea, which might
be quite similar to your machine.  The alsa and sound related stuff
should be similar to the 2.6.7 config, an almost similar config worked
for me with the 2.6.7 as well.

Ofcourse getting a debian kernel-image is easier, however I had
problems with acpi compiled as modules. It doesn't hurt to try a
kernel-image, you could install as many as you like. For kernel
compiling, I would recommend kernel-package if  are not using it
already, which will create a kernel-image.deb.  apt-get remove
kernel-image-blah will also safely remove unwanted ones as well.

Regarding sound, the only thing I remember doing extra is installing
alsa-base and alsa-utils (which I believe you already have, since
alsamixer is a part of alsa-utils iirc). I remember running 6 or 7
instances of mplayer and sound still worked on all of them without
fiddling with dmix or asound etc. My hunch is that your sound issues
are on the package level and not kernel related.

"QM_Modules: function not implemented for both."  - do you have
module-init-tools installed?



Reply to: