[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ATI RADEON questions

Good morning all,

After much questioning, I've finally bought an ATI Radeon 9200 for my
Debian system.

I still have some minor issues with it, here they are, hoping that
someone will be able to help out...

- CPU runs at a higher load when idle: according to the cpu load of
gkrellm, the cpu is 15-20% busy when idle with the ATI card, compared to
4-5% with any other card I've tested. The same services run on both case
so it's not a question of having added functionalities to the system
between the card swap. Top gives similar readings.

- I get these warnings in /var/log/XFree86.0.log :

(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(WW) Open APM failed (/dev/apm_bios) (No such device)

--> I thought 3D acceleration was enabled by default ? What am I
forgetting ?

- Now, let's examine a bit of my XF86Config-4 file :

# This loads the GLX module
    Load        "glx"   # libglx.a
    Load        "dri"   # libdri.a

Since these two lines aren't commented, wouldn't 3D accel load
properly ?

- Last subsection (a bit above the one about glx / dri) :

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA

--> Why is it omitted ? I actually need the DGA extension to get a
full-screen vmware guest OS. Every time I fire up VMWare, it complains
of that missing extension. If I enable it, it seems that fglrx won't
load at boot-up (I tried previously and got the errors in the log to
prove it :) ).

Any help would be appreciated.


PS: on a footnote: before buying that card (which, above issues
notwhistanding I *love*), I tried an Nvidia GEForce/MX4000. Oh yeah,
nvidia brags about its linux support.. Go and try the latest driver
(v6629 at the time I bought it).. The driver as what they
euphimistically call "issues" with linux-2.6.10 --> it garbles the
screen, damn it ! Downgrading the driver won't work, it fails to load.
Switching to 2.6.9 won't help either. They've been made aware of these
problems awhile back, and still, no driver update since november (or
later ? can't recall exactly). Way to go, nvidia.

Anyway.. this is a Radeon-post, not an nvidia-post, I was just venting
some frustration. Any help on the Radeon questions would be appreciated.
Thanks :)

Reply to: