[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Determining a device

On Tue, 04 Jan 2005 13:15:45 -0800, Steve Lamb <grey@dmiyu.org> wrote:
>      I'm attempting to get my Canon LiDE 20 scanner working.  So far it works,
> kind of.  I can find it with lsusb.  When I run xsane as a normal user it
> cannot find the device.  However when I run xsane as root it does find it.
> xsane's help suggests this is because of a permissions problem on the device
> entry itself.  The problem is I have no clue what device entry the scanner is
> coming in as?  The most likely candidates I've found from /etc/sane.d/* don't
> work when I chown them to my normal user account.  Those being /dev/scanner
> and /dev/sg0.  Any ideas how I can get from the USB listing to the proper
> device entry in /dev?

Have you added your user to the, IIRC, "scanner" group? I should check
if what i suggested is the correct group, you should find the details
in the sane documentation.


Reply to: