[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Determining a device

On Tue, 2005-01-04 at 13:15 -0800, Steve Lamb wrote:
>      I'm attempting to get my Canon LiDE 20 scanner working.  So far it works, 
> kind of.  I can find it with lsusb.  When I run xsane as a normal user it 
> cannot find the device.  However when I run xsane as root it does find it. 
> xsane's help suggests this is because of a permissions problem on the device 
> entry itself.  The problem is I have no clue what device entry the scanner is 
> coming in as?  The most likely candidates I've found from /etc/sane.d/* don't 
> work when I chown them to my normal user account.  Those being /dev/scanner 
> and /dev/sg0.  Any ideas how I can get from the USB listing to the proper 
> device entry in /dev?

What kernel are you running?
Is hotplug installed?

1. Unplug the scanner's USB cable from the PC.
2. In a new, large xterm window: sudo tail -f -n40 /var/log/syslog
3. Plug in the scanner's USB cable.
4. Watch what gets dumped into /var/log/syslog.

Ron Johnson, Jr.
Jefferson, LA USA
PGP Key ID 8834C06B I prefer encrypted mail.

"The United States is not a nation to which peace is a
Grover Cleveland

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: