[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel 2.8.x (was: cdrecord & cdwriter)

On Wed, Nov 03, 2004 at 12:25:15PM +0200, Martin Fluch wrote:
> >P.S. I use the kernel 2.6.8-1-386 version 2.6.8-4
> There is some issue with the kernel and cdwriting. The only 
> infromation I have about this is from k3b.org (in the news section):
>     "Do not use Kernel 2.6.8
>     A patch that was introduced into the kernel shortly before the 2.6.8
>     release makes K3b and also the dvd+rw-tools unusable on Linux (unless
>     run as root but that is not recommended). The very important GET
>     CONFIGURATION MMC command is rejected by the kernel for reasons I
>     cannot see and writing commands like MODE SELECT also fail (K3b cannot
>     detect CD writers without it) even when the device is opened O_RDWR.
>     Until this issue has been solved I strongly recommend to stick to
>     kernel version 2.6.7.
>     Update: The kernel guys are currently fixing the problem so the next
>     kernel release should work again. :)
>     Update 2: The problem is NOT fixed in
>     Update 3: Be aware that kernel 2.6.8 also contains the memory leak
>     which makes it impossible to write audio cds, even as root."
> I myself had no problem using k3b with 2.6.9 and 2.6.7 kernels (and k3b 
> uses cdrecord to burn CDs).

Thanks for your advices.

I have encountered problems with kernel 2.8.6 and xmms which worked fine as 
root but not as user. I posted a question about this to the list xmms-dev and
their reply was: change the permission of /dev/hdc.

The permission origine of /dev/hdc was 660, I put it to 644 and now xmms
works fine for the users. It's a problem with gtk whilst cdcd have no problem. 
It works fine for the users with 660 for /dev/hdc. (and 4755 for cdcd)
I tried to put 4755 to xmms but I received a protest of gtk.
( reason of security: http://www.gtk.org/setuid.html ) 

Now I have upgraded with kernel  2.9.1 and the problem of permission with xmms
are identical.

I wonder if I am messing my system in changing the permissions of /dev/hdc ?


Reply to: