[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

cdrecord & cdwriter



Hi all,
Sorry
This has been answered many times but i am not able to sort and solve mine.
Could any one  pls help me
Here are the details below i installed a LG cdwriter
when i do cdrecord -scanbus it gives as:-

cdrecord -scanbus
Cdrecord-Clone 2.01a27 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <cdrtools@packages.debian.org>.
      The original author should not be bothered with problems of this version.

cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord:
cdrecord: For more information, install the cdrtools-doc
cdrecord: package and read /usr/share/doc/cdrecord/README.ATAPI.setup .
sh-2.05b#

but when i give cdrecord -scanbus dev=ATAPI

 cdrecord -scanbus dev=ATAPI
Cdrecord-Clone 2.01a27 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <cdrtools@packages.debian.org>.
      The original author should not be bothered with problems of this version.

scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.8'.
scsibus0:
        0,0,0     0) 'HL-DT-ST' 'CD-RW GCE-8525B ' '1.03' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *

dmesg | grep ATAPI
hdc: HL-DT-ST GCE-8525B, ATAPI CD/DVD-ROM drive
hdc: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache
scsi0 : SCSI host adapter emulation for IDE ATAPI devices

cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda2       /home           ext3    defaults        0       2
/dev/hda5       /usr            ext3    defaults        0       2
/dev/hda6       none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/scd0       /cdrom          iso9660 ro,user,noauto,exec     0       0

and i have added a line in /boot/grub/menu.lst as
 
append "/dev/hdc=ide-scsi"
 

Wiht all these when i do eject i get the following as root and normal user
#eject
 
eject: unable to eject, last error: Inappropriate ioctl for device
 

mount /cdrom
mount: /dev/scd0 is not a valid block device
 

I just need to use cdrecord and burn cds
pls tell me where am i going wrong and how do i rectify it..

Regards,
Vijaya
 
 


Reply to: