[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debian-installer: partman, limited; base-install failed, grave error?


If there have been bug reports filed for these issues, please let me know.

I'm using a Pentium (586) class computer (AMD K6-2 running at 262 MHz in a
system running at 75 MHz FSB, 37.5 MHz PCI bus), with 128 MB of EDO DRAM.  The
system appears to be stable, and has run at this bus speed for over a year,
but with an Intel 133 non-MMX CPU and an older BIOS.  Mainboard's Intel 430HX
chipset is using the Intel 82371SB PIIX3 IDE chipset.  Network card is LinkSys
LNE100TX v5.1.

I'm trying to install a fresh copy of Debian unstable using the unstable
boot/root floppies from 20040715.

Initially I tried expert mode, as I'm an experienced user.  I've been
successfully installing various flavors of Linux since 1997, and Debian since
2001.  :-)

Expert mode failed to install the base system.

I tried the basic or normal mode (just hit ENTER at the boot prompt).  The
base-install fails there as well.

I am not sure what to look for in the syslog or messages files.  Near the
beginning of the install, I skip the "load drivers from disk", as there are no
esoteric devices in this machine, and ide-related modules are reported as
"missing" (ide-mod, ide-probemod, ide-detect, ide-generic, ide-floppy,
ide-disk, ide-cd, isofs).  The installation guide and howto say that only the
boot and root disks are generally required.  If this has changed, then the
documentation is stale and misleading!  (I'm doing a net-install, so get
everything besides the network driver from the net!  Right?  That's how
net-install used to be defined...)  later on, ide-modules and ide-core-modules
are installed, yet hw-detect still complains about 4 ide modules missing:
ide-mod, ide-probe-mod, ide-generic, and ide-floppy, thus it proceeds to
preselect all ide chipset modules in expert, install all ide chipset modules
in normal, despite me only needing piix, which the kernel recognizes on floppy
bootup.  hw-detect then complains again about all the missing ide modules
previously listed.  Is it completely retarded or what?

Anyways, there are also several error messages about package dependency
failures, packages failing to install because a required package has not been
installed.  The very first error I see is dpkg install of base-passwd, which
complains that libc6 is not installed.  Yet the dependencies are ignored.  I
am not sure if this is normal just to get things going, or how to determine
the first error which I should worry about.  In this example, libc6 seems to
be installed later on (according to messages), so probably nothing to worry

There are numerous other pre-depemndancy problems, unpacked but not
configured, error processing libgnutls11 (--configure), hostname: Unknown host
(despite my having specified it earlier through the installer).  The last
error in messages is about the libgnutls11 package:

Errors were encountered while processing:

At first, I tried doing partitioning and formatting myself.  I do not like the
partitioning program at all, it's too limited (doesn't recognize my
configuration, formats the disk without asking me for options).   I prefer
partitioning my own disks and formatting my own drives before writing data to
them.  On this vintage system, I like to squeeze out every last bit of the
1.2GB disk space that I can.  It's usually more than enough for a text-only
installation.  I partition the disk with /dev/hda1 as a Primary partition, 128
MB, to use as swap, set it bootable and maximize (NC), and usually install a
boot loader there (on the MBR).  The second and only other partition is an
Extended partition with 1 Logical partition containing the rest of the
approximate 1.1GB of space.  I prefer ext2 for the performance on this older
system, as I can live perfectly fine with an occasional e2fsck.  I usually
format the partition with -b 1024 (standard size), and -i 8192 (8 x standard
1024), as I have found I can convert some inode space to data space, and have
plenty of inodes left.  I've been doing this for years with no problems, so
please,no comments that the non-standard configuration makes you queasy or you
find it untasteful.  ;-)  But do comment if I need to be aware that something
has dramatically changed where the cfdisk maximize (NC) flag, boot loader on
swap partition or primary and extended partition mixing causes critical errors
in Linux. If the configuration would cause an error, then why do the tools
(fdisk/cfdisk/partman) not recognize and warn about this specific error?

I have tried using partman to generate the partitions, automated formatting
(even after I zeroed the beginning of the disks): 1 primary 128 MB swap, 1
extended with 1 logical ext2 and also tried with ext3.  The base-install still

Additionally, with the normal install, netcfg tries to run mii-diag, which
fails, yet the network card gets an IP address from my local DHCP server, and
connects just fine through the net and downloads files.

Ah, in syslog, there's something interesting:

Jul 30 00:57:30 base-installer: error: exiting on error
Jul 30 00:57:41 main-menu[370]: (process:17071): ^Mtmp                    0%
                           |     0       --:-- ETA
Jul 30 00:57:41 main-menu[370]: (process:17071): ^Mtmp                  100%
***************************| 34068       00:00 ETA
Jul 30 00:57:41 main-menu[370]: (process:17071):
Jul 30 00:57:41 main-menu[370]: (process:17071): Connecting to
Jul 30 00:57:41 main-menu[370]: (process:17071): ls:
Jul 30 00:57:41 main-menu[370]: (process:17071): /usr/lib/base-installer.d/*
Jul 30 00:57:41 main-menu[370]: (process:17071): : No such file or directory
Jul 30 00:57:41 main-menu[370]: WARNING **: Configuring 'base-installer'
with error code 1
Jul 30 00:57:41 main-menu[370]: WARNING **: Menu item 'base-installer'

Could this be the cause of all the problems?  ;-)  How to fix it?  Someone
forget to upload a file, or am I using the wrong server for an install?  If I
should use another server for install, it would be wise not to select this
server by default, and also to warn about WHY it failed, perhaps by installing
a dummy package which alerts you of the problem, instead of having me download
a bunch of files, and mysteriously fail to install after they've downloaded. 



Reply to: