[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: BT Voyager 1010 (or Linksys WUSB11)

Ron wrote:

Jonathan Melhuish wrote:

Jonathan Melhuish wrote:

There must surely be a table that translates these numeric codes into
the right driver to load - anyone got any idea where it is?
Yeah, I got an idea where it is.  It is in the driver.  Look at
at76c503-rfmd.c of your berlios source directory.  Your vendor 0x69a is
there as dyna link, but your product 0x821 is not.  At least this is the
case in my version from back in December.

Hmm, I tried to modify it "properly" so that I can send my changes back
to the authors.  Here's the diff:

#define VENDOR_ID_BT                  0x69a
#define PRODUCT_ID_BT_VOYAGER_1010    0x821

I did a make, make install, but still the message in the system log is
the same (not claimed by any active driver).  I tried typing "modprobe
-v at76c503-rfmd" again but to no avail.

Just as an aside, how do I get the proper diff output with filenames and
line numbers and stuff, so that you can use "patch"?

I got a chuckle earlier, but
this is your chance to modify that puppy and reconfigure.  I'd just follow
the convention that exists in the file for WUSB11.
Bleh, don't listen to them!  Linux isn't what it is today /just/ because
of the hardcore coders, ya know - it's people like you who test, hack,
document and support these things that really makes Linux into a quality
product.  :-)



Reply to: