[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg/ucf hang (was: Re: [users] Problem in starting OOo and its reinstallation)

Hi Derrick,

Thanks for your advice

On Tue, 2003-12-30 at 04:43, Derrick 'dman' Hudson wrote:

> | > It hanged there compelling me to close the Koncole window.
> | I don't doubt it.
> | > Then I ran;
> | > # dpkg --configure -a
> | > Setting up foomatic-filters (3.0.0-20031207-1) ...
> | > Configuration file `/etc/foomatic/filter.conf'
> | >  ==> File on system created by you or by a script.
> | >  ==> File also in package provided by package maintainer.
> | >    What would you like to do about it ?  Your options are:
> | >     Y or I  : install the package maintainer's version
> | >     N or O  : keep your currently-installed version
> | >       D     : show the differences between the versions
> | >       Z     : start a new shell to examine the situation
> | >  The default action is to keep your current version.
> | > ***  filter.conf  (Y/I/N/O/D/Z) [default=N] ?  D/Y/N and <Enter> (I tried all 
> | > of them).  It hanged here again.
> There's a bug, somewhere, that I just discovered last night and this
> morning.
> The process (in my case it was 'ucf' for both packages) gets stuck in
> the Sleeping state and doesn't receive any keyboard input.
> I don't know what the bug is, but I do know the two ways I worked around it :
>     a)  when ucf hangs, look at the command line parameters using
>         pstree or gnome-system-monitor.  run it manually and update
>         the config file so that ucf/dpkg doesn't detect a difference
>         and doesn't prompt you
>     b)  edit /var/lib/dpkg/info/PKG.postinst to remove the invocation
>         of ucf on the config file that is different and you don't want
>         changed anyways
> Of course, the applicability of these workarounds depends on what the
> config file is, what you want to do with it, and how the package is
> organized.
> Based on Stephen's description, I think the following programs are not
> to blame :
>     aptitude, xterm, dselect, konsole
> but these haven't been ruled out :
>     dpkg, ucf
> I know that running ucf manually does not reveal the issue.

I also received advice from other lists (not OOo) that some folks there
also met this problem same as mind.  They are still searching hard for a

> PS. Stephen:  sometimes things don't work quite right when running
>     unstable.  I recommend not running unstable unless :
>         1)  you know what you are doing and how debian is organized
>             (and can debug and workaround such issues yourself)
>     or
>         2)  the system isn't terribly important and you can leave it
>             in a broken state until someone else fixes the bug
>     or
>         3)  you like learning to swim by jumping in the deep end
>             (see #1)
>     FWIW I run a testing+unstable mix and accept the fact that the
>     latest and greatest sometimes has problems and I can deal with
>     them.  It works well for me.

I make this test on Debian in anticipation of learning its technology. 
I used 'Sarge-net-installation' because in my idea it will bring me the
up-to-date Debian OS similar to as I did in installing Gentoo 1.4
previously.  But I met with several problems. With the assistance of
folks on this list I have overcome all of them.  But the problem here
seems having no end.  Now after upgrade Kmail can't send mail but can
receive mails.  It looks to me a little bid funny.

I am prepared to remove this box soon after hearing some more
suggestions of remedy on existing problems because I expect to learn
through making mistake.  Thereafter I will reinstall Debian 3.0 from CDs
to continue my exploration on Debian

Anyway thanks again.


Reply to: