[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: D-link DFE-530tx

Hi all...

D-Link cards seem to give more people some trouble :). Well, see inline text for my answers this time...


ScruLoose wrote:

On Sat, Nov 01, 2003 at 03:14:56PM +0100, Kurt Sys wrote:
Quoting Rob Weir <rweir@ertius.org>:
On Sat, Nov 01, 2003 at 12:03:54PM +0100, Kurt Sys said
I have to install a new computer. I install Debian Woody (3.0r1) from
boot-CD (CD1 -- NON-US). Everything works fine except for one thing, I can't
get my ethernet card to work. I found on the net several people with similar
or the same problem, but I don't find an answer. So, here it is (again).
The network card is a D-link DFE-530tx. Following different sources, I need
the via-rhine module, but this won't work. Any other driver also doesn't
This usually means the module is already loaded, or in the case of the
Debian install kernels, that the module is built in.  Have you checked
"dmesg" to see if your card is already detected?
Thanks for your reply (and the replies of others, but no, I didn't check 'dmesg'
yet. I add here some more output. I upgraded to  kernel 2.4.18 (which is on CD1
also), and tried the most obvious possibilities (via-rhine, sundance and realtek
modules). I didn't include any of them in the kernel, so they won't be in the
kernel, I guess, and they cannot be inserted as a module.

I've got the same card, and it gave me a bunch of trouble... I'm not
sure how much of what I did is the "right" way (or how much help it'll
be to you), but I've got the thing working.
Now, when you say that the via-rhine module "cannot be inserted", do you
mean that when you do a modprobe via-rhine you get some output that ends
in "installation failed"?

This answers the question, I guess...

----- modprobe via-rhine -----
/lib/modules/2.2.20-idepci/net/via-rhine.o: init_module: Device or resource busy
/lib/modules/2.2.20-idepci/net/via-rhine.o: insmod
/lib/modules/2.2.20-idepci/net/via-rhine.o failed
/lib/modules/2.2.20-idepci/net/via-rhine.o: insmod via-rhine failed

If I try a hard way:
for i in * ; do modprobe $i ; done
I get for all modules (including via-rhine.o, tulip.o, etc.):
'Modprobe: Can't locate module xxx.o'

I'm no expert at reading dmesg output, but it looks to me like your
current kernel does have a via-rhine module, and is trying (repeatedly)
to load it.  I _think_ that's what all those lines starting with
via-rhine.c must mean.

I'm neither an expert in reading dmesg, that's why I did put it on this list :).

If your case is like mine, that's just the beginning. When I compiled a
2.4.21 kernel (from debian.org source, it called itself a "testing"
package, but seemed to install with no dependency issues) with via-rhine
as a module, the module inserted w/ no complaints, but the card
continued not to work...

I know it doesn't work with kernel 2.4.18. I'm now busy downloading Knoppix. Apparently some people have good experiences with it.

But after adding "noapic" to the append line in lilo.conf (so it's
passed to the kernel as an argument at boot) then the card works... as
long as I "ifconfig eth0 up" with the right arguments on the _first_
If I for any reason do an ifconfig eth0 down and then bring it up again,
it's dead.  Any traffic just gets a "NETDEV WATCHDOG: eth0: connection
timed out" error, and the only thing that'll revive it is a reboot.

In general, my conclusion is that the DFE-530TX is a cantankerous little
bugger, and next time I need a NIC I'll buy a different brand.

The worst part is that I've heard a rumour saying the DFE-530TX comes
with various different chipsets, so if yours is from a different
batch/week/moodswing than mine, it may not be via-rhine at all. I don't
actually _know_ this, but I've heard it on this mailing list.

Well, I guess so. Some people use 'via-rhine', others 'tulip' and others sundance etc. etc. I tried them all... but with kernel 2.4.18

Oh, and just in case they're some help, here are a couple of posts I
made while I was trying to figure it out:


I'll check them, I guess.
However, I'll try the Knoppix-way first. See what that can do...

Reply to: