[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wxWindows + building from source in Debian

Mark Roach wrote:
On Mon, 2003-10-20 at 07:06, Dave Howorth wrote:
dpkg-checkbuilddeps: Unmet build dependencies: libgtk1.2-dev, python (>=2.3), python2.3-dev, libpng2-dev, libtiff3g-dev, xlibmesa-gl-dev | libgl-dev, xlibmesa-glu-dev | libglu-dev, libesd0-dev
dpkg-buildpackage: Build dependencies/conflicts unsatisfied; aborting.

The general question is why the dependencies weren't picked up when I did the apt-get source? And is there in principle a general way to resolve them or do I have to apt-get them all individually.

apt-get build-dep <packagename>

Thanks for that.

The specific question is why these particular dependencies are arising.
The reason is that all of those wxwindows packages come from the same
source package. Why exactly did you decide that you needed to compile
the whole thing again?

The full story is in the previous messages, which I trimmed to save bandwidth :) But briefly, I need wxWindows to be able to build a specific non-Debian application. wxWindows is not supported on Woody, which is what I run. Hence, I need to compile it. Not sure what you mean by again?

Cheers, Dave

Reply to: