[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pppd daemon dies is a permissions problem? failure


J Y (<jhy@x-mail.net>) wrote:

> I tried some other things like 1) uncommenting the auth line in
> /etc/ppp/options> I tried to apt-get install ppp and the response was
> the current version is the most recent. I ran linuxconf and made sure
> I was in the ppp group-I am. 

My Debian system does not have a ppp group. This seems to be something
linuxconf-specific. By default, the group you must be in to use pppd is

andreas@sirius:~$ ll /usr/sbin/pppd
-rwsr-xr--    1 root     dip        230604 10. Dez 2001  /usr/sbin/pppd

andreas@sirius:~$ ll -d /etc/ppp/peers
drwxr-s---    2 root     dip          1024 15. Sep 23:49 /etc/ppp/peers

andreas@sirius:~$ ll /etc/ppp/peers
-rw-r-----    1 root     dip           579 20. Jul 23:30 provider
-rw-r-----    1 root     dip           275 15. Sep 23:49 T-Online

> I also uncommented debug in
> /etc/ppp/ttyS4 options. That's my modem. When I ran kppp this time, as
> a regular user the message from kppp was: "timeout expired while
> waiting for the PPP interface to come up". The detail box provided:
> Oct  1 17:15:16 deblnx pppd[1049]: pppd 2.4.1 started by john, uid
> 1000
> Oct  1 17:15:46 deblnx pppd[1049]: Terminating on signal 15.
> Oct  1 17:15:46 deblnx pppd[1049]: Connect script failed
> Oct  1 17:15:46 deblnx pppd[1049]: Exit.

Check the pppd man page for the meaning of its exit codes. This one

The link was terminated because the peer is not responding to echo

This happens to me sometimes when I try do dial. When I try again, it
works. Did you try several times or only once?

best regards
        Andreas Janssen

Andreas Janssen
PGP-Key-ID: 0xDC801674
Registered Linux User #267976

Reply to: