[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.18 pcmcia troubles



On Tue, Aug 05, 2003 at 05:53:18AM +0000, Andrew McGuinness wrote:
> ScruLoose wrote:
> >On Fri, Aug 01, 2003 at 04:34:07PM -0400, ScruLoose wrote:

> You have the kernel-pcmcia-modules-2.4.18-586tsc package as well, I 
> assume.  (I think so, that's probably where i82365 comes from).

Yep. I've actually upgraded to 2.4.18-1-586tsc now, but I made sure to
get the corresponding new kernel-pcmcia-modules as well.

> >>So I try modprobe i82365 and it complains thus:
> >>Intel PCIC Probe: not found
> >>/lib/modules/2.4.18-586tsc/kernel/drivers/pcmcia/i82365.o: init_module:
> >>No such device.
> >>and after a couple more lines, insmod fails.
> >>
> You do have pcmcia_core first (it's still there in 2.4)

Yep. pcmcia_core loads successfully during the boot into 2.4. (it
shows up in lsmod)...

> >>Now, since it all *worked* on the 2.2.x kernel with the i82365 module,
> >>I'm assuming that's the right one for my hardware... And my 2.4.x
> >>modules tree does indeed *have* that module, it just won't load.
> >
> >Since my last message, I've tried kernel 2.4.18-1-586tsc as well. It
> >continues to fail in exactly the same way as the 2.4.18-586tsc did.
> >During boot, the bit that smells like the root of the problem goes
> >something like this:
> >
> >i82365
> >Loading i82365
> >...
> >Linux Kernel Card Services 3.1.22
> >  options: [pci] [cardbus] [pm]
> >Intel PCIC probe: not found.
> >unloading Kernel card services
> >
> >(I remember seeing the first two lines go by during boot, the rest is
> >out of dmesg).
> >
> what does lspci say?

For this kind of output it's preferred *not* to wrap my lines, right?
Here goes:

00:00.0 Host bridge: Intel Corp. 430MX - 82437MX Mob. System Ctrlr (MTSC) & 82438MX Data Path (MTDP) (rev 02)
00:01.0 Bridge: Intel Corp. 430MX - 82371MX Mobile PCI I/O IDE Xcelerator (MPIIX) (rev 03)
00:03.0 PCMCIA bridge: Cirrus Logic CL 6729 (rev e2)
00:06.0 VGA compatible controller: Neomagic Corporation NM2070 [MagicGraph NM2070] (rev 01)

And, just for the sake of argument, the full output of modprobe i82365 
under my current kernel:

isapnp: Scanning for PnP Cards...
isapnp: No Plug & Play device found
Intel PCIC probe: not found.
/lib/modules/2.4.18-1-586tsc/kernel/drivers/pcmcia/i82365.o: init_module: No such device
/lib/modules/2.4.18-1-586tsc/kernel/drivers/pcmcia/i82365.o: insmod /lib/modules/2.4.18-1-586tsc/kernel/drivers/pcmcia/i82365.o failed
/lib/modules/2.4.18-1-586tsc/kernel/drivers/pcmcia/i82365.o: insmod i82365 failed
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters


> The iptables firewalling capability is more flexible than the stuff that 
> was in 2.2
> 
Okay, good to know that I'm fighting this fight for good reason.

-- 
,-------------------------------------------------------------------------.
>   -ScruLoose-   |              WARNING:  Contains Language!             <
>  Please do not  |                      - Neil Gaiman                    <
> reply off-list. |                                                       <
`-------------------------------------------------------------------------'

Attachment: pgpKC7sc7bQs2.pgp
Description: PGP signature


Reply to: