[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.4.18-586tsc pcmcia troubles



Hey all,

I can't seem to get my pcmcia network cards working after an upgrade to
the 2.4.18-586tsc kernel (from Debian kernel-image package).

Under the 2.2.x-bf kernel, I had at least one card working fine with
the pcnet_cs module. Other relevant-looking modules that were loaded at
the time are 8390 and ds (used by pcnet_cs), i82365, and pcmcia_core
(used by pcnet_cs, ds and i82365).

Now, when I try to modprobe pcnet_cs it complains about "ds: no socket
drivers loaded!" and insmod fails.

If I understand things rightly, i82365 is a socket driver... yes?

So I try modprobe i82365 and it complains thus:
Intel PCIC Probe: not found
/lib/modules/2.4.18-586tsc/kernel/drivers/pcmcia/i82365.o: init_module:
No such device.
and after a couple more lines, insmod fails.

Well, I went a-Googling, and found this thread:
http://lists.debian.org/debian-laptop/2003/debian-laptop-200302/msg00093.html
so I tried to modprobe yenta_socket, which responded with a similar
"init_module: no such device" and insmod fails.

Now, since it all *worked* on the 2.2.x kernel with the i82365 module,
I'm assuming that's the right one for my hardware... And my 2.4.x
modules tree does indeed *have* that module, it just won't load.

So what do I try next?

This is all under woody on an old Hitachi laptop, Pentium 133...
It ain't gonna be much use as a firewall until I get the network cards
working! :P

-- 
,-------------------------------------------------------------------------.
>   -ScruLoose-   |       Check out the coolest radio station ever:       <
>  Please do not  |                 www.radioparadise.com                 <
> reply off-list. |                                                       <
`-------------------------------------------------------------------------'

Attachment: pgpeAZJCkgoZx.pgp
Description: PGP signature


Reply to: