[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.18 pcmcia troubles



ScruLoose wrote:
On Fri, Aug 01, 2003 at 04:34:07PM -0400, ScruLoose wrote:

Hey all,

I can't seem to get my pcmcia network cards working after an upgrade to
the 2.4.18-586tsc kernel (from Debian kernel-image package).

You have the kernel-pcmcia-modules-2.4.18-586tsc package as well, I assume. (I think so, that's probably where i82365 comes from).

So I try modprobe i82365 and it complains thus:
Intel PCIC Probe: not found
/lib/modules/2.4.18-586tsc/kernel/drivers/pcmcia/i82365.o: init_module:
No such device.
and after a couple more lines, insmod fails.

You do have pcmcia_core first (it's still there in 2.4)

Well, I went a-Googling, and found this thread:
http://lists.debian.org/debian-laptop/2003/debian-laptop-200302/msg00093.html
so I tried to modprobe yenta_socket, which responded with a similar
"init_module: no such device" and insmod fails.

Now, since it all *worked* on the 2.2.x kernel with the i82365 module,
I'm assuming that's the right one for my hardware... And my 2.4.x
modules tree does indeed *have* that module, it just won't load.


Since my last message, I've tried kernel 2.4.18-1-586tsc as well. It
continues to fail in exactly the same way as the 2.4.18-586tsc did.
During boot, the bit that smells like the root of the problem goes
something like this:

i82365
Loading i82365
...
Linux Kernel Card Services 3.1.22
  options: [pci] [cardbus] [pm]
Intel PCIC probe: not found.
unloading Kernel card services

(I remember seeing the first two lines go by during boot, the rest is
out of dmesg).

what does lspci say?


BTW, the reason why I don't just stick with the 2.2.20 kernel which
works is that I've read that the ipmasq implementation has been
substantially improved in the 2.4 kernels. If this is not true and I'm
barking up the wrong tree, feel free to point that out.

The iptables firewalling capability is more flexible than the stuff that was in 2.2


	Thanks for any help.

Attachment: pgpjnv_ETIq4y.pgp
Description: PGP signature


Reply to: