[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.18 pcmcia troubles

On Fri, Aug 01, 2003 at 04:34:07PM -0400, ScruLoose wrote:
> Hey all,
> I can't seem to get my pcmcia network cards working after an upgrade to
> the 2.4.18-586tsc kernel (from Debian kernel-image package).

Me again... No luck so far. I've noticed no responses to this over the
few days since I posted it.  I hope I haven't asked a FAQ or an
unforgivably stupid question here. I've tried to include the relevant
details and all that...

> Under the 2.2.x-bf kernel, I had at least one card working fine with
> the pcnet_cs module. Other relevant-looking modules that were loaded at
> the time are 8390 and ds (used by pcnet_cs), i82365, and pcmcia_core
> (used by pcnet_cs, ds and i82365).
> Now, when I try to modprobe pcnet_cs it complains about "ds: no socket
> drivers loaded!" and insmod fails.
> If I understand things rightly, i82365 is a socket driver... yes?
> So I try modprobe i82365 and it complains thus:
> Intel PCIC Probe: not found
> /lib/modules/2.4.18-586tsc/kernel/drivers/pcmcia/i82365.o: init_module:
> No such device.
> and after a couple more lines, insmod fails.
> Well, I went a-Googling, and found this thread:
> http://lists.debian.org/debian-laptop/2003/debian-laptop-200302/msg00093.html
> so I tried to modprobe yenta_socket, which responded with a similar
> "init_module: no such device" and insmod fails.
> Now, since it all *worked* on the 2.2.x kernel with the i82365 module,
> I'm assuming that's the right one for my hardware... And my 2.4.x
> modules tree does indeed *have* that module, it just won't load.

Since my last message, I've tried kernel 2.4.18-1-586tsc as well. It
continues to fail in exactly the same way as the 2.4.18-586tsc did.
During boot, the bit that smells like the root of the problem goes
something like this:

Loading i82365
Linux Kernel Card Services 3.1.22
  options: [pci] [cardbus] [pm]
Intel PCIC probe: not found.
unloading Kernel card services

(I remember seeing the first two lines go by during boot, the rest is
out of dmesg).

Are there command-line options I should be passing to the i82365
module? Should I be trying a different kernel version? What are the
chances that compiling my own kernel will make a difference?
In short, what do I try next?  
If this is addressed somewhere, pointers to relevant docs will be
gratefully accepted.

BTW, the reason why I don't just stick with the 2.2.20 kernel which
works is that I've read that the ipmasq implementation has been
substantially improved in the 2.4 kernels. If this is not true and I'm
barking up the wrong tree, feel free to point that out.

	Thanks for any help.
>   -ScruLoose-   |       If we do not believe in freedom of speech       <
>  Please do not  |                  for those we despise                 <
> reply off-list. |            we do not believe in it at all.            <
>                 |                     - Noam Chomsky                    <

Attachment: pgpw85g6AGNLy.pgp
Description: PGP signature

Reply to: